Mailinglist Archive: opensuse-factory (475 mails)

< Previous Next >
[opensuse-factory] Recovering from accidentally removing /var/lib/rpm/Packages
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Sat, 02 Aug 2008 00:58:04 +0100
  • Message-id: <4893A30C.3000605@xxxxxxxxxxxxxxxx>
Tried "rpm --rebuilddb, "rpm --initdb". There was a directory named /var/lib/rpmrebuilddb.8774 which I also tried renaming to /var/lib/rpm.
Not all installed packages appear, also file to package association is missing for some packages, e.g:-
tindog:/var/lib # rpm -q pidgin
package pidgin is not installed
tindog:/var/lib # which pidgin
tindog:/var/lib # rpm -qf /usr/bin/pidgin
file /usr/bin/pidgin is not owned by any package
# pidgin -h
Pidgin 2.4.3

Last factory update 30th. July, currently "zypper dup" doing just under 1 Gig of updates.

Any ideas?

Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot
Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support Specialist, Cricket Coach
Microsoft Windows Free Zone - Linux used for all Computing Tasks

To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups