Mailinglist Archive: opensuse-factory (905 mails)

< Previous Next >
Re: [opensuse-factory] Re: RC1
  • From: Russ Fineman <russbucket@xxxxxxx>
  • Date: Tue, 3 Jun 2008 10:00:20 -0700
  • Message-id: <200806031000.20345.russbucket@xxxxxxx>
On Tuesday 03 June 2008 09:11:01 am Vahis wrote:
russbucket wrote:
Vahis wrote:
Russ Fineman wrote:
Has anyone tried using the update for installing RC1? I have 11.0 beta3
installed and want to do RC1 without total reinstall if possible. I
looked at the delta iso but I apparently deleted beta 3 iso but mistake
so i don't have it and I understand I would need it for the delta
version to work. Is this correct?

I have. But on a virtual machine only. On that vm I had the normal
Packman stuff, multimedia worked fine.
I also had had Apache/MySQL/Php. Amarok configured to use MySQL The
Amarok database was dumped from my real machine.
I had PhpMyadmin, too. They all worked fine. Then I went:

#zypper ref

#zypper dup -l

Taht's it. Everyhting worked fine :)

Executed the above commands and go the following:
zypper dup -l
Reading installed packages...

The following NEW packages are going to be installed:
smp_utils sdparm lsscsi

Overall download size: 190.0 K. After the operation, additional 658.0 K
will be used.
Continue? [YES/no]: YES
Downloading package smp_utils-0.93-9.i586 (1/3), 91.0 K (422.0 K
unpacked) Downloading: smp_utils-0.93-9.i586.rpm [done]
Installing: smp_utils-0.93-9 [done]
Downloading package sdparm-1.02-9.i586 (2/3), 75.0 K (183.0 K unpacked)
Downloading: sdparm-1.02-9.i586.rpm [done]
Installing: sdparm-1.02-9 [done]
Downloading package lsscsi-0.19-9.i586 (3/3), 24.0 K (53.0 K unpacked)
Downloading: lsscsi-0.19-9.i586.rpm [done]
Installing: lsscsi-0.19-9 [done]
linux:~ # uname -a
Linux linux #1 SMP 2008-05-26 15:23:05 +0200 i686 i686
i386 GNU/Linux

linux:~ # cat /etc/SuSE-release
openSUSE 11.0 (i586)
VERSION = 11.0

How can I tell if I'm actually on RC1? The uname comand and cat of
SuSE-release do not say, only 11.0.

Thanks for the help. I can always install RC one from the DVD I made.

Rc1 is not a release. All the way from alphas via betas to rc is a
continuous chain of changes.
They are all 11.0, just not released and under development, snapshots of
factory at given times.

If you keep going with zypper dup you'll end up with the release.
Then you need to change the repos to point to 11.0, otherwise you'll
have 11.1 factory again :)

I had saved a snapshot of the original installation of beta3 which I
updated. So I got hundreds of packages (over 800 I think).
You obviously updated a system which already had almost everything
updated from the factory repos?

I had waited for the RC1 and the frozen factory repos to do the update.
Thanks. I had been doing updates all along fron YaST ->online update->package
groups. So i must be up todate. I'm waiting for the final release so I can
get rid os some problems with 10.3 (shutdown) 11.0 works.

Thanks again for your help. I'll learn all this stuff someday. I use GUI's but
am also comfortable with command line. Thats all we had in the old days of
assembler and machine language control.

Linux register user 441463
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >