Mailinglist Archive: opensuse-factory (393 mails)

< Previous Next >
Re: [opensuse-factory] Linux audio foks
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Mon, 12 Mar 2007 12:11:24 +0000
  • Message-id: <45F5436C.5070306@xxxxxxxxxxxxxxxx>
Donn Washburn wrote:
Sid Boyce wrote:
Donn Washburn wrote:
Hey Group;

I have the record player > phono In > line out going to the sound card
Line In. Hopefully the impedance is good enough and the level is OK.
It plays out of the speakers and sounds OK also. Now for the question ?
I would like to save the music as a mp3, ogg or whatever. Kmix spots it
as a Line Input. What is needed to capture it and put it in a file.
Say like a mixer record output


No luck with audacity?
The Input selections in 1.3.2 are Vol, Line, Mic, CD, Line1, Phonein, Phoneout and Video. You should then be able to record from the Line input.

File --> Export as --> MP3 or whatever format.
Regards
Sid.
The problem is Sid;
That Audacity will only work as a user if you change the permissions on /dev/dsp. I tried several and only 777 seem to work. However, Audacity will only "Record" once and then it fails on the second try. Now this may be a "Me" problem understanding the way it saves data. I have fixed it by removing /home/donn/.audacity-data and trying it again. It ask for lang. which I set and then it comes up with full features.


I and several others have had similar permissions problems with gizmo which actually said there was no audio device. I did strace and submitted it to the forum, but the mystery continued. Then I had a brainwave, tried it as root and it was AOK. So I added the user to audio in /etc/group, also did the same for video a while back when kaffeine complained about no video, though OK with audio.
was
audio:x:17:
now
audio:x:17:lancelot
video:x:33:lancelot

It's a strange behaviour, stuff used to come up with ownerships in /dev of e.g <user>:audio, then quite a while ago on Mandriva and more recently on openSUSE, they are "root:audio", so the user can't get to them. Don't know whether it's a bug or feature, but it's a gotcha. Most apps work, but there is always one or two that experience the problem. It's only last week I got this problem when I fired up gizmo the first time in months.
Without the changes my DVB card would complain when kaffeine is fired up.
# l -R /dev/dvb
/dev/dvb:
total 0
drwxr-xr-x 3 root root 60 2007-03-10 07:27 ./
drwxr-xr-x 13 root root 16520 2007-03-12 00:19 ../
drwxr-xr-x 2 root root 120 2007-03-10 07:27 adapter0/

/dev/dvb/adapter0:
total 0
drwxr-xr-x 2 root root 120 2007-03-10 07:27 ./
drwxr-xr-x 3 root root 60 2007-03-10 07:27 ../
crw-rw----+ 1 root video 212, 4 2007-03-10 07:27 demux0
crw-rw----+ 1 root video 212, 5 2007-03-10 07:27 dvr0
crw-rw----+ 1 root video 212, 3 2007-03-10 07:27 frontend0
crw-rw----+ 1 root video 212, 7 2007-03-10 07:27 net0

Regards
Sid.
--
Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot
Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support Specialist, Cricket Coach
Microsoft Windows Free Zone - Linux used for all Computing Tasks

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups