Mailinglist Archive: opensuse-factory (592 mails)

< Previous Next >
Re: [opensuse-factory] X.org 7.2-1.2 in Beta1?
  • From: "Bruce A. Mallett" <bam@xxxxxxxxxxxxxx>
  • Date: Sat, 28 Oct 2006 16:54:06 -0400
  • Message-id: <4543C36E.5070300@xxxxxxxxxxxxxx>
Jens Nixdorf wrote:
> Hi all,
>
> just installed Beta 1 onto my Notebook and almost everything was working
> fine except X.org. My notebook runs a ATI X 1600 Mobility and while this
> chip isnt supported by X.org itself (radeon does work only up to X850,
> none of the X1x00-Chips are supported) Sax2 chooses VESA Framebuffer for
> it.
>
> I dont have to tell you that the framebuffer is very slow, it looks also
> very ugly, because the notebook has a native resolution of 1280x800,
> which is not usable with the framebuffer.
>
> So i wanted to install the proprietary ATI-driver 8.29.6, which even can
> make a package for SUSE 10.2. But from the console Sax2 cannot start
> with sax2 -r -m 0=fglrx, because the fglrx-driver is detecting a
> X.org-Version 7.2-1.2 instead of a 7.1.99. I found this in the SaX.log:
>
> (II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
> (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
> compiled for 7.1.0, module version = 8.29.6
> Module class: X.Org Video Driver
> ABI class: X.Org Video Driver, version 1.0
> [atiddxSetup] X version mismatch - detected X.org 7.2.-1.2, required
> X.org 7.1.0.0
> (II) UnloadModule: "fglrx"
> (II) Unloading /usr/lib/xorg/modules/drivers//fglrx_drv.so
> (EE) Failed to load module "fglrx" (module requirement mismatch, 0)
>
> At any other place in this and other logs X.org is stated as Version
> 7.1.99, where is this 7.2-1.2 from? And what can i do to have the right
> resolution (with or without the fglrx-driver)?
>
> Thanks, Jens
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
> For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx
>
I am having the same problem with a v5200 ATI on a Thinkpad T60p.
Normally ATI releases a new set of drivers about every month and it is a
little slow coming this month. Perhaps delayed to get a SUSE 10,2
compatible release (I hope)?

- Bruce

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
References