Mailinglist Archive: opensuse-factory (757 mails)

< Previous Next >
Re: [opensuse-factory] tagmedia question
On Thu, May 04, 2006 at 12:19:00PM -0400, Kenneth Schneider wrote:
> On Thu, 2006-05-04 at 12:12 +0200, Ulrich Windl wrote:
> > On 4 May 2006 at 12:03, Steffen Winterfeldt wrote:
> >
> > > yast & checkmedia show you the md5sum of the final iso, which, given the
> > > current state of cryptography and computing power can not be stored in the
> > > iso itself, (...)
> >
> > I always wondered where K3B finds the checksum to check an ISO image against...
>
> It doesn't get it from anywhere, it creates one from the iso file that
> -you- are supposed to check against the one supplied by the maker of the
> iso.

I am not talking about downloading MD5SUMS to the same directory as the 5
iso's are. I am talking about the mediacheck that happens during the
installation

I tried it again and now suddenly it works. No idea why it did not before.
very strange it did not work before.
So this is what I do:
1) makeSUSEdvd (with only CD1)
2) tagmedia --md5 --pad 150 --check DVD_DIR/SUSE-10.1-0-DVD.iso
3) Boot it in Parallels

I even have 3 movies made that shows it a bit better
Standard SUSE iso. Does a check
http://houghi.org/film/md5_test_ok.avi 2.1M

Standard makeSUSEdvd. Does no check. It goes directly to the next step.
http://houghi.org/film/md5_no_test.avi 845K

After the tagmedia. This is untill where the checksums go wrong. I also
skipped most of the checking of the checksum. You just have to believe me
that it went to 100%
http://houghi.org/film/md5_own_ok.avi 11M

Must be the music I was listening to. :-)

houghi
--
Nutze die Zeit. Sie ist das Kostbarste, was wir haben, denn es
ist unwiederbringliche Lebenszeit. Leben ist aber mehr als Werk
und Arbeit, und das Sein wichtiger als das Tun - Johannes Müller-Elmau

< Previous Next >