Mailinglist Archive: opensuse-es (625 mails)

< Previous Next >
Re: [opensuse-es] Re: Audacity no puede importar mas wma
  • From: Juan Erbes <jerbes@xxxxxxxxx>
  • Date: Tue, 9 Nov 2010 09:16:02 -0300
  • Message-id: <AANLkTi=0HatUGRGq0=_m_O6VqkQr1pePuXAXoOJgSFqQ@xxxxxxxxxxxxxx>
El día 9 de noviembre de 2010 06:28, Camaleón <noelamac@xxxxxxxxx> escribió:
El Mon, 08 Nov 2010 20:49:37 -0300, Juan Erbes escribió:

El día 8 de noviembre de 2010 16:27, Camaleón escribió:

Ah, yo tengo un grabador de la misma marca, ya descatalogado (Olympus
WS-300M)... probemos:

sm01@stt008:~/Desktop$ file ws_30003.wma ws_30003.wma: Microsoft ASF

No parece que usen ningún códec extraño.

Pero si lo importo al Audacity (1.2.6)... meec, dice que no admite ese
formato.


Voy a repetir algo del comienzo del hilo:

"Pero por lo que pude ver, no soy el unico que tiene este problema:

http://www.mail-archive.com/packman@xxxxxxxxxxxxxx/msg04588.html

http://permalink.gmane.org/gmane.comp.package-management.packman/4605

La versión que tengo de Audacity, es la 1.3.12-beta (Unicode), y segun
el link quie posteó Cesar (también dijo que en Ubuntu tiene el mismo
problema):

http://audacity.sourceforge.net/help/faq?s=files&i=wma-proprietary

"Audacity 1.2 no puede importar o exportar AC3, AMR(NB), M4A, WMA o
muchos otros formatos propietarios por problemas de licencia y
restricciones de patentes. De todos modos, la versión 1.3 beta de
Audacity puede importar y exportar estos y otros formatos si se instala
la biblioteca opcional FFmpeg . FFmpeg además permite a Audacity
importar audio desde archivos de vídeo"

Pues eso, que la versión beta (la que tienes) sí debería poder importar
wma... si no lo hace:

a) Es un fallo del Audacity
b) Es un fallo del ffmpeg

Si el ffmpeg te permite convertir el wma a cualquier otro formato (como
ves a mí sí me deja), el fallo es del Audacity.


Justamente, como dice en el ultimo link, el problema es audacity, pero
tiene que ver con la versión de ffmpeg:

http://manual.audacityteam.org/index.php?title=FAQ:Installation_and_Plug-Ins#installffmpeg

For users compiling Audacity:

* FFmpeg from SVN after June 1st 2010 may cause Audacity not to
compile with error "invalid conversion from ‘int (*)(URLContext*,
unsigned char*, int)’ to ‘int (*)(URLContext*, const unsigned char*,
int)’" in FFmpeg.cpp:257. Workaround: change src/FFmpeg.cpp line 207
from "static int ufile_write(URLContext *h, unsigned char *buf, int
size)" to "static int ufile_write(URLContext *h, const unsigned char
*buf, int size)"
* Any FFmpeg libraries or packages built in 2010 may not be
recognised by Audacity (Help > Show Log will list an error "undefined
symbol: match_ext"). Workaround: Re-compile Audacity and change all
instances of "match_ext" in ../src/FFmpeg.h and ../src/FFmpeg.cpp to
"av_match_ext".

El problema, es que quienes empaquetan audacity, parece que no han
tenido en cuenta esto.

Salu2
--
Para dar de baja la suscripción, mande un mensaje a:
opensuse-es+unsubscribe@xxxxxxxxxxxx
Para obtener el resto de direcciones-comando, mande
un mensaje a:
opensuse-es+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups