Mailinglist Archive: opensuse-es (1154 mails)

< Previous Next >
Re: [suse-linux-s] Uso puerto paralelo.
  • From: José "Rodriguez S." <telecopower@xxxxxxxxxxxxxx>
  • Date: 05 Oct 2003 13:49:45 +0200
  • Message-id: <1065354584.3200.18.camel@xxxxxxxxxxxxxxxxxxxxxx>
Hola.

Ya verigué lo de listar los módulos (lsmod) y me salió esto, esntre
otras cosas, más relacionado con el puerto. Digo esto porque el programa
que quiero usar me pide que haga un mknod con parport0 y tal:

lp 6400 0 (autoclean)
parport 25352 1 (autoclean) [parport_pc lp]

Al tratar de cargar los módulos que me comentas me sale:

pivenet:/home/telecopower # modprobe ipp
modprobe: Can't locate module ipp

pivenet:/home/telecopower # modprobe ppa
/lib/modules/2.4.20-4GB-athlon/kernel/drivers/scsi/ppa.o: init_module:
No such device
Hint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-4GB-athlon/kernel/drivers/scsi/ppa.o: insmod
/lib/modules/2.4.20-4GB-athlon/kernel/drivers/scsi/ppa.o failed
/lib/modules/2.4.20-4GB-athlon/kernel/drivers/scsi/ppa.o: insmod ppa
failed
pivenet:/home/telecopower #


o sea, que el módulo no lo tengo, no?


El dom, 05 de 10 de 2003 a las 13:35, Rafa Grimán escribió:
> Hola :)
>
>
> --------- Mensage Original --------
> De: José Rodriguez S. <telecopower@xxxxxxxxxxxxxx>
> Para: Suse <suse-linux-s@xxxxxxxx>
> Asunto: Re: [suse-linux-s] Uso puerto paralelo.
> Fecha: 05/10/03 12:00
>
> > [...]
> > Cuando uso el puerto para imprimir todo va de maravilla pero al mandar
> > datos al programador las luces del mismo se vuelven locas.
> >
> > Tengo el programa que me dices hecho en C, no por mí sino por unos de
> > microbótica, y usa la función outportb. Se supone que pone todo el
> > puerto a 1, pidiendo los permisos, claro, y se mide con el tester pero
> > nada. El programa marca en consola que todo fue bien pero cuando mides
> > va cada pin a su bola y no sé por qué no puedo usar el puerto sino para
> > imprimir.
>
>
> Comprueba que tengas cargados los módulos:
>
> ipp
>
> o
>
> ppa
>
> No me acuerdo de cuál es, sólo recuerdo que se cargaban al usar iomega-zip
> de puerto paralelo. Posiblemente sea lo que necesites.
>
>
> --
> rgriman@xxxxxxx http://www.suse.de/es
> http://www.suse.com
>
> rafael.griman@xxxxxxxxxxxxx http://www.hispalinux.es
>
> rafa@xxxxxxxxxxxxx
> registered Linux user 286102 http://counter.li.org/
>
> "One of the joys of being a kid is that experiences are new and therefore
> more intense."
--
José Rodríguez S.
Linux User #324770


< Previous Next >
Follow Ups
References