Mailinglist Archive: opensuse-de (3756 mails)

< Previous Next >
Re: PHP-Update Apache2
On Sat, Sep 25, 2004 at 01:03:36AM +0200, Christian Boltz wrote:
[2] Komischerweise gibt es aber keine Paketabhängigkeiten zwischen
Apache2 und PHP...

Das ist schwer hinzukriegen. Fuer Subversion habe ich es mal
eingebaut, weil es da wenig offensichtlich ist, auch libapr0 zu
updaten, [...]

Vor allem umgekehrt ist es aber nicht moeglich, eine Abhaengigkeit
einzubauen -- Apache soll ja nicht unbedingt PHP erfordern, aber
"wenn" dann vom FTP-Server... das geht ueber die Moeglichkeiten von
'rpm' hinaus.

Naja, Du könntest es doch umgekehrt machen: PHP benötigt
Apache2 = 2.0.50-6.1
Ob das Apache2- oder das PHP-RPM den Fehler wirft, ist eigentlich
egal ;-)

Außerdem kann man mit ein paar Tricksereien auch "weiche" Abhängigkeiten
in RPMs bauen. Eigenkonstruktion im Spec der Fontlinge, hier zur
besseren Lesbarkeit umgebrochen:

[...]

Das sind gute Anregungen. Vielen Dank! Ich hoffe dass ich demnaechst
Zeit finde, etwas davon zu realisieren.

Peter
< Previous Next >