Mailinglist Archive: opensuse-de (5757 mails)

< Previous Next >
pppoe mit SuSE 6.2
  • From: Ralf Cirksena <ci@xxxxxxxxx>
  • Date: 2 Oct 2002 06:18:00 GMT
  • Message-id: <ane32o$pq4$1@xxxxxxxxxxxxxxxx>
Hallo,

ich habe meinem ältlichen Linux-Router (abgespeckte SuSE 6.2) jetzt
ADSL-Fähigkeit verpasst.

Dabei trat folgendes Problem auf:
Nach Inbetriebnahme mit pppd pty "pppoe -I eth1"

Using interface ppp0
Connect: ppp0 <--> /dev/ttyp1
pppoe: socket: Session 0: Invalid argument
Script pppoe -I eth1 finished (pid 357), status = 0x100
Modem hangup

Der selbstkompilierte Kernel 2.2.10 führt zu der Fehlermeldung, der
SuSE-Kernel (Binary von 6.2) funktioniert. Aus verschiedenen Gründen
möchte ich wieder einen selbstkompilierten Kernel einsetzen, habe aber
offensichtlich entscheidende Optionen falsch gesetzt.

In welcher Gegend der Kernel-Konfig soll ich anfangen zu suchen? Ich
möchte das zielgerichtet tun, da der Kompilerlauf auf einem 486er
einige Zeit in Anspruch nimmt. Vielen Dank im Voraus.

Konfiguration/Versionsinfos:

Kernel: 2.2.10
pppd: 2.4.1
rp-pppoe: 3.5

Ausgabe von ifconfig (eth0 ist internes Netz):
eth0 Link encap:Ethernet HWaddr 00:00:86:52:20:D3
inet addr:192.168.1.152 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:514 errors:0 dropped:0 overruns:0 frame:0
TX packets:554 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
Interrupt:3 Base address:0x300

eth1 Link encap:Ethernet HWaddr 00:50:BA:73:F6:11
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
Interrupt:5 Base address:0x320

--
Ralf Cirksena <ci@xxxxxxxxx>

< Previous Next >
Follow Ups