Mailinglist Archive: opensuse-de (4938 mails)

< Previous Next >
Re: QT 2.1.0 + KDE2
  • From: bjkro@xxxxxx (Bjoern Krombholz)
  • Date: Tue May 16 00:25:34 2000
  • Message-id: <3920957E.C0BB2D85@xxxxxx>



Philipp Thomas wrote:
* Bjoern Krombholz (bjkro@xxxxxx) [20000515 19:05]:
Allerdings kann es bei einigen Programmen zu Konflikten kommen, wenn
sie nur gegen libqt.so gelinkt sind und nicht gegen
libqt.so.<version>.
Entschuldige, aber das ist ziemlicher Blödsinn [...]
Ist entschuldigt ;)

Als Bibliothek, von der ein Programm abhängig ist, wird dagegen der interne
Name der Bibliothek, der sog. soname eingetragen. Dieses ist meist
lib<name>.so.<major version>.

Hast natürlich recht, hab geschrieben, ohne vorher nachzudenken.
Ich persönlich hatte auch nur Probleme mit QT-2.0- und QT-2.1-
gelinkten Programmen.

Björn

---------------------------------------------------------------------
To unsubscribe, e-mail: suse-linux-unsubscribe@xxxxxxxx
For additional commands, e-mail: suse-linux-help@xxxxxxxx

< Previous Next >
Follow Ups
References