Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit python-lmfit for openSUSE:Factory
Hello community,

here is the log from the commit of package python-lmfit for openSUSE:Factory
checked in at 2019-04-30 13:00:02
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/python-lmfit (Old)
and /work/SRC/openSUSE:Factory/.python-lmfit.new.5536 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "python-lmfit"

Tue Apr 30 13:00:02 2019 rev:4 rq:697388 version:0.9.13

Changes:
--------
--- /work/SRC/openSUSE:Factory/python-lmfit/python-lmfit.changes
2019-03-06 15:48:55.144426463 +0100
+++ /work/SRC/openSUSE:Factory/.python-lmfit.new.5536/python-lmfit.changes
2019-04-30 13:00:06.906176234 +0200
@@ -1,0 +2,29 @@
+Wed Apr 24 08:42:15 UTC 2019 - pgajdos@xxxxxxxx
+
+- version update to 0.9.13
+ New features:
+ Clearer warning message in fit reports when uncertainties should
+ but cannot be estimated, including guesses of which Parameters
+ to examine (#521, #543)
+ SplitLorenztianModel and split_lorentzian function (#523)
+ HTML representations for Parameter, MinimizerResult, and Model
+ so that they can be printed better with Jupyter (#524, #548)
+ support parallelization for differential evolution (#526)
+ Bug fixes:
+ delay import of matplotlib (and so, the selection of its backend)
+ as late as possible (#528, #529)
+ fix for saving, loading, and reloading ModelResults (#534)
+ fix to leastsq to report the best-fit values, not the values tried
+ last (#535, #536)
+ fix synchronization of all parameter values on Model.guess() (#539, #542)
+ improve deprecation warnings for outdated nan_policy keywords (#540)
+ fix for edge case in gformat() (#547)
+ Project managements:
+ using pre-commit framework to improve and enforce coding style (#533)
+ added code coverage report to github main page
+ updated docs, github templates, added several tests.
+ dropped support and testing for Python 3.4.
+- deleted patches
+ - lmfit-scipy.patch (upstreamed)
+
+-------------------------------------------------------------------

Old:
----
lmfit-0.9.12.tar.gz
lmfit-scipy.patch

New:
----
lmfit-0.9.13.tar.gz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ python-lmfit.spec ++++++
--- /var/tmp/diff_new_pack.DR1mc4/_old 2019-04-30 13:00:07.910176010 +0200
+++ /var/tmp/diff_new_pack.DR1mc4/_new 2019-04-30 13:00:07.914176009 +0200
@@ -18,34 +18,33 @@

%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name: python-lmfit
-Version: 0.9.12
+Version: 0.9.13
Release: 0
Summary: Least-Squares Minimization with Bounds and Constraints
License: MIT AND BSD-3-Clause
Group: Development/Languages/Python
Url: https://lmfit.github.io/lmfit-py/
Source:
https://files.pythonhosted.org/packages/source/l/lmfit/lmfit-%{version}.tar.gz
-Patch0: lmfit-scipy.patch
BuildRequires: %{python_module setuptools}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
# SECTION test requirements
-BuildRequires: %{python_module asteval}
-BuildRequires: %{python_module numpy}
+BuildRequires: %{python_module asteval >= 0.9.12}
+BuildRequires: %{python_module numpy >= 1.10}
BuildRequires: %{python_module pytest}
-BuildRequires: %{python_module scipy}
-BuildRequires: %{python_module six}
-BuildRequires: %{python_module uncertainties}
+BuildRequires: %{python_module scipy >= 0.19}
+BuildRequires: %{python_module six >= 1.10}
+BuildRequires: %{python_module uncertainties >= 3.0}
# /SECTION
-Requires: python-asteval
-Requires: python-numpy
-Requires: python-scipy
-Requires: python-six
+Requires: python-asteval >= 0.9.12
+Requires: python-numpy >= 1.10
+Requires: python-scipy >= 0.19
+Requires: python-six >= 1.10
Recommends: python-dill
Recommends: python-emcee
Recommends: python-matplotlib
Recommends: python-pandas
-Recommends: python-uncertainties
+Recommends: python-uncertainties >= 3.0
BuildArch: noarch

%python_subpackages
@@ -71,7 +70,6 @@

%prep
%setup -q -n lmfit-%{version}
-%patch0 -p1
sed -i -e '/^#!\//, 1d' lmfit/jsonutils.py

%build

++++++ lmfit-0.9.12.tar.gz -> lmfit-0.9.13.tar.gz ++++++
++++ 10350 lines of diff (skipped)


< Previous Next >
This Thread
  • No further messages