Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit uwsgi for openSUSE:Factory
Hello community,

here is the log from the commit of package uwsgi for openSUSE:Factory checked
in at 2019-04-30 12:58:39
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/uwsgi (Old)
and /work/SRC/openSUSE:Factory/.uwsgi.new.5536 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "uwsgi"

Tue Apr 30 12:58:39 2019 rev:32 rq:697293 version:2.0.18

Changes:
--------
--- /work/SRC/openSUSE:Factory/uwsgi/uwsgi.changes 2019-02-11
21:25:31.323076160 +0100
+++ /work/SRC/openSUSE:Factory/.uwsgi.new.5536/uwsgi.changes 2019-04-30
12:58:42.202139066 +0200
@@ -1,0 +2,6 @@
+Sat Mar 16 00:45:25 UTC 2019 - James Oakley <jfunk@xxxxxxxxxxxxxx>
+
+- Add patch uwsgi-2.0.18-postgresql-config.patch to use pkg-config
+ instead of pg_config as it was removed in postgres11-devel
+
+-------------------------------------------------------------------

New:
----
uwsgi-2.0.18-postgresql-config.patch

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ uwsgi.spec ++++++
--- /var/tmp/diff_new_pack.ryJ9mm/_old 2019-04-30 12:58:43.742140289 +0200
+++ /var/tmp/diff_new_pack.ryJ9mm/_new 2019-04-30 12:58:43.754140298 +0200
@@ -1,7 +1,7 @@
#
# spec file for package uwsgi
#
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


@@ -40,6 +40,8 @@
Patch2: uwsgi-1.9.13-objc_gc-no-fobjc-gc.patch
# PATCH-FIX-OPENSUSE uwsgi-1.9.11-systemd_logger-old_systemd.patch - Older
systemd in 12.2 does not implicity include syslog.h
Patch3: uwsgi-1.9.11-systemd_logger-old_systemd.patch
+# PATCH-FIX-OPENSUSE uwsgi-2.0.18-postgresql-config.patch - Use pkg-config
instead of pg_config
+Patch4: uwsgi-2.0.18-postgresql-config.patch
%define apache_branch %(rpm -q --qf %%{version} apache2 | grep -E -o
"2\\.[0-9]+")
%if "%{apache_branch}" == "2.4"
%define apxs %{_bindir}/apxs2
@@ -441,6 +443,7 @@
%patch1 -p1
%patch2 -p1
%patch3 -p1
+%patch4 -p1
# Generate a config that builds all plugins except for examples and stuff we
# can't satisfy the requirements for or are just broken
excluded_plugins=""

++++++ uwsgi-2.0.18-postgresql-config.patch ++++++
--- a/plugins/emperor_pg/uwsgiplugin.py
+++ b/plugins/emperor_pg/uwsgiplugin.py
@@ -2,11 +2,8 @@ import os

NAME = 'emperor_pg'

-CFLAGS = ['-I' + os.popen('pg_config --includedir').read().rstrip()]
+CFLAGS = os.popen('pkg-config --cflags libpq').read().rstrip().split()
LDFLAGS = []
-LIBS = [
- '-L' + os.popen('pg_config --libdir').read().rstrip(),
- '-lpq'
-]
+LIBS = os.popen('pkg-config --libs libpq').read().rstrip().split()

GCC_LIST = ['emperor_pg']

< Previous Next >
This Thread
  • No further messages