Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit libkgapi for openSUSE:Factory
Hello community,

here is the log from the commit of package libkgapi for openSUSE:Factory
checked in at 2019-04-26 22:50:56
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/libkgapi (Old)
and /work/SRC/openSUSE:Factory/.libkgapi.new.5536 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "libkgapi"

Fri Apr 26 22:50:56 2019 rev:45 rq:696340 version:19.04.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/libkgapi/libkgapi.changes 2019-03-11
11:12:44.513389732 +0100
+++ /work/SRC/openSUSE:Factory/.libkgapi.new.5536/libkgapi.changes
2019-04-26 22:50:57.717443666 +0200
@@ -1,0 +2,29 @@
+Sat Apr 20 06:51:58 UTC 2019 - lbeltrame@xxxxxxx
+
+- Update to 19.04.0
+ * New feature release
+ * For more details please see:
+ * https://www.kde.org/announcements/announce-applications-19.04.0.php
+- No code changes since 19.03.90
+
+-------------------------------------------------------------------
+Tue Apr 09 20:54:44 UTC 2019 - lbeltrame@xxxxxxx
+
+- Update to 19.03.90
+ * New feature release
+ * For more details please see:
+ * https://kde.org/announcements/announce-applications-19.04-rc.php
+- Changes since 19.03.80:
+ * Workaround qt5.13 bug
+
+-------------------------------------------------------------------
+Wed Mar 27 06:41:08 UTC 2019 - lbeltrame@xxxxxxx
+
+- Update to 19.03.80
+ * New feature release
+ * For more details please see:
+ * https://kde.org/announcements/announce-applications-19.04-beta.php
+- Changes since 18.12.3:
+ * Too many changes to list here
+
+-------------------------------------------------------------------

Old:
----
libkgapi-18.12.3.tar.xz

New:
----
libkgapi-19.04.0.tar.xz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ libkgapi.spec ++++++
--- /var/tmp/diff_new_pack.O1kTSI/_old 2019-04-26 22:50:58.217443410 +0200
+++ /var/tmp/diff_new_pack.O1kTSI/_new 2019-04-26 22:50:58.217443410 +0200
@@ -20,7 +20,7 @@
%{!?_kapp_version: %define _kapp_version %(echo %{version}| awk -F. '{print
$1"."$2}')}
%bcond_without lang
Name: libkgapi
-Version: 18.12.3
+Version: 19.04.0
Release: 0
Summary: Extension for accessing Google data
License: GPL-2.0-or-later AND LGPL-2.1-or-later
@@ -28,17 +28,21 @@
URL: http://www.kde.org
Source0: %{name}-%{version}.tar.xz
BuildRequires: cyrus-sasl-devel
-BuildRequires: extra-cmake-modules >= 1.0.0
+BuildRequires: extra-cmake-modules >= 5.55.0
BuildRequires: kcalcore-devel
BuildRequires: kcontacts5-devel
-BuildRequires: kcoreaddons-devel
-BuildRequires: kdelibs4support-devel
BuildRequires: kf5-filesystem
+BuildRequires: ki18n-devel
+BuildRequires: kio-devel
BuildRequires: kwallet-devel
-BuildRequires: pkgconfig
+BuildRequires: kwindowsystem-devel
+BuildRequires: cmake(Qt5Core) >= 5.10.0
BuildRequires: cmake(Qt5LinguistTools)
-BuildRequires: pkgconfig(Qt5Test) >= 5.2.0
-BuildRequires: pkgconfig(Qt5WebEngineWidgets) >= 5.6.0
+BuildRequires: cmake(Qt5Network) >= 5.10.0
+BuildRequires: cmake(Qt5Test) >= 5.10.0
+BuildRequires: cmake(Qt5WebEngineWidgets) >= 5.10.0
+BuildRequires: cmake(Qt5Widgets) >= 5.10.0
+BuildRequires: cmake(Qt5Xml) >= 5.10.0
# It can only build on the same platforms as Qt Webengine
ExclusiveArch: %{ix86} x86_64 %{arm} aarch64 mips mips64

@@ -126,7 +130,6 @@
Group: Development/Libraries/KDE
Requires: kcalcore-devel
Requires: kcontacts5-devel
-Requires: kcoreaddons-devel
Requires: libKPimGAPIBlogger5 = %{version}
Requires: libKPimGAPICalendar5 = %{version}
Requires: libKPimGAPIContacts5 = %{version}

++++++ libkgapi-18.12.3.tar.xz -> libkgapi-19.04.0.tar.xz ++++++
++++ 12636 lines of diff (skipped)


< Previous Next >
This Thread
  • No further messages