Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit gwenhywfar for openSUSE:Factory
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory
checked in at 2019-04-25 16:22:21
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
and /work/SRC/openSUSE:Factory/.gwenhywfar.new.5536 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "gwenhywfar"

Thu Apr 25 16:22:21 2019 rev:65 rq: version:4.20.1

Changes:
--------
--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes 2019-04-24
13:57:31.323983434 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.5536/gwenhywfar.changes
2019-04-25 16:22:25.202054032 +0200
@@ -2,22 +1,0 @@
-Tue Apr 23 15:44:53 UTC 2019 - Michele Bologna <michele.bologna@xxxxxxxx>
-
-- Fixed typo in changelog file
-
--------------------------------------------------------------------
-Mon Mar 25 17:48:25 UTC 2019 - Christophe Giboudeaux <christophe@xxxxxxx>
-
-- Prepare the KDE4/Qt4 removal from factory.
-- Run spec-cleaner
-
--------------------------------------------------------------------
-Wed Jan 30 21:34:35 CET 2019 - sbrabec@xxxxxxxx
-
-- Update to version 4.99.8 (beta) required by libchipcard-5.1.2:
- * Generalization in the generic TLV to GWEN DB parser.
- * Speedup of GWEN_Date_dup (about factor 16).
- * Correctly read a UTF-8-encoded MT940 file.
- * Updated Gwengui-Gtk3.
- * API improvements.
- * Other fixes.
-
--------------------------------------------------------------------

Old:
----
gwenhywfar-4.99.8beta.tar.gz

New:
----
gwenhywfar-4.20.1.tar.gz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ gwenhywfar.spec ++++++
--- /var/tmp/diff_new_pack.Tdfhhj/_old 2019-04-25 16:22:25.674053935 +0200
+++ /var/tmp/diff_new_pack.Tdfhhj/_new 2019-04-25 16:22:25.674053935 +0200
@@ -1,7 +1,7 @@
#
# spec file for package gwenhywfar
#
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
@@ -12,24 +12,26 @@
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

-# Please submit bugfixes or comments via https://bugs.opensuse.org/
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

-
-%define libversion 78
-%define devversion 5
-%define devrelease 4.99
-# Beta does not mean "before release" but a release that is considered as beta:
-%define _version %{version}beta
+%bcond_without qt4
%bcond_with configure
+%define libname libgwenhywfar60
+%define devversion 4.20
Name: gwenhywfar
-Version: 4.99.8
+Version: 4.20.1
Release: 0
Summary: Multiplatform helper library for other libraries
-License: GPL-2.0-or-later AND LGPL-2.1-or-later
+License: GPL-2.0+ and LGPL-2.1+
Group: System/Libraries
-URL: https://www.aquamaniac.de/rdm/projects/gwenhywfar
-Source:
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{name}-%{_version}.tar.gz
+Url: http://www.aqbanking.de/
+Source:
https://github.com/aqbanking/gwenhywfar/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
+%if !%{with configure}
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libtool
+%endif
BuildRequires: doxygen
BuildRequires: fdupes
# For doc graphs
@@ -37,8 +39,12 @@
BuildRequires: graphviz-gd
BuildRequires: libgcrypt-devel >= 1.2.0
BuildRequires: libopenssl-devel
-BuildRequires: pkgconfig
-BuildRequires: xorg-x11-fonts
+%if %{with qt4}
+%if 0%{?suse_version} >= 1500
+#!BuildIgnore: libopenssl-1_0_0-devel
+%endif
+BuildRequires: libqt4-devel
+%endif
BuildRequires: cmake(Qt5Concurrent)
BuildRequires: cmake(Qt5Core)
BuildRequires: cmake(Qt5DBus)
@@ -50,20 +56,16 @@
BuildRequires: cmake(Qt5Test)
BuildRequires: cmake(Qt5Widgets)
BuildRequires: cmake(Qt5Xml)
-BuildRequires: pkgconfig(gnutls) >= 2.9.8
-BuildRequires: pkgconfig(gtk+-2.0) >= 2.17.5
-BuildRequires: pkgconfig(gtk+-3.0) >= 3.14.0
-Recommends: libgwenhywfar%{libversion}
-%if !%{with configure}
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: libtool
-%endif
%if 0%{?fedora} == 15
BuildRequires: fox-devel >= 1.6
%else
BuildRequires: fox16-devel
%endif
+BuildRequires: xorg-x11-fonts
+BuildRequires: pkgconfig(gnutls) >= 2.9.8
+BuildRequires: pkgconfig(gtk+-2.0) >= 2.17.5
+BuildRequires: pkgconfig(gtk+-3.0) >= 3.14.0
+Recommends: %{libname}

%description
Gwenhywfar is a base library used to provide OS abstraction functions
@@ -74,9 +76,9 @@

%package tools
Summary: Multiplatform Helper Library for Other Libraries - Tools
-License: GPL-2.0-or-later AND LGPL-2.1-or-later
+License: GPL-2.0+ and LGPL-2.1+
Group: System/Libraries
-Requires: libgwenhywfar%{libversion} = %{version}
+Requires: %{libname} = %{version}

%description tools
Gwenhywfar is a base library used to provide OS abstraction functions
@@ -85,27 +87,27 @@
configuration files, reading and writing of XML files, and interprocess
communication).

-%package -n libgwenhywfar%{libversion}-plugins
+%package -n %{libname}-plugins
Summary: Multiplatform Helper Library for Other Libraries - Plugins
-License: LGPL-2.1-or-later
+License: LGPL-2.1+
Group: System/Libraries
Requires: %{name} = %{version}

-%description -n libgwenhywfar%{libversion}-plugins
+%description -n %{libname}-plugins
Gwenhywfar is a base library used to provide OS abstraction functions
for Linux, FreeBSD, OpenBSD, NetBSD, and Windows. It also includes
some often needed functions (for example, for handling and parsing of
configuration files, reading and writing of XML files, and interprocess
communication).

-%package -n libgwenhywfar%{libversion}
+%package -n %{libname}
Summary: Multiplatform Helper Library for Other Libraries
-License: LGPL-2.1-or-later
+License: LGPL-2.1+
Group: System/Libraries
Recommends: %{name}-lang
-Recommends: libgwenhywfar%{libversion}-plugins = %{version}
+Recommends: %{libname}-plugins = %{version}

-%description -n libgwenhywfar%{libversion}
+%description -n %{libname}
Gwenhywfar is a base library used to provide OS abstraction functions
for Linux, FreeBSD, OpenBSD, NetBSD, and Windows. It also includes
some often needed functions (for example, for handling and parsing of
@@ -114,7 +116,7 @@

%package -n libgwengui-cpp0
Summary: C++ interface for Gwenhywfar
-License: GPL-2.0-or-later AND LGPL-2.1-or-later
+License: GPL-2.0+ and LGPL-2.1+
Group: System/Libraries

%description -n libgwengui-cpp0
@@ -122,7 +124,7 @@

%package -n libgwengui-gtk2-0
Summary: Multiplatform Helper Library for Other Libraries -- GTK+ 2 UI
Backend
-License: LGPL-2.1-or-later
+License: LGPL-2.1+
Group: System/Libraries

%description -n libgwengui-gtk2-0
@@ -136,7 +138,7 @@

%package -n libgwengui-gtk3-0
Summary: Multiplatform Helper Library for Other Libraries -- GTK+ 3 UI
Backend
-License: LGPL-2.1-or-later
+License: LGPL-2.1+
Group: System/Libraries

%description -n libgwengui-gtk3-0
@@ -148,12 +150,24 @@

This package provides the GTK+ 3 implementation of the generic UI toolkit.

+%package -n libgwengui-qt4-0
+Summary: Multiplatform Helper Library for Other Libraries -- Qt4 UI
Backend
+License: LGPL-2.1+
+Group: System/Libraries
+
+%description -n libgwengui-qt4-0
+Gwenhywfar is a base library used to provide OS abstraction functions
+for Linux, FreeBSD, OpenBSD, NetBSD, and Windows. It also includes
+some often needed functions (for example, for handling and parsing of
+configuration files, reading and writing of XML files, and interprocess
+communication).
+
+This package provides the Qt4 implementation of the generic UI toolkit.
+
%package -n libgwengui-qt5-0
Summary: Multiplatform Helper Library for Other Libraries -- Qt5 UI
Backend
-License: LGPL-2.1-or-later
+License: LGPL-2.1+
Group: System/Libraries
-Provides: libgwengui-qt4-0 = %{version}
-Obsoletes: libgwengui-qt4-0 < %{version}

%description -n libgwengui-qt5-0
Gwenhywfar is a base library used to provide OS abstraction functions
@@ -166,7 +180,7 @@

%package -n libgwengui-fox16-0
Summary: FOX interface for Gwenhywfar
-License: GPL-2.0-or-later AND LGPL-2.1-or-later
+License: GPL-2.0+ and LGPL-2.1+
Group: System/Libraries

%description -n libgwengui-fox16-0
@@ -175,14 +189,17 @@

%package devel
Summary: Multi-Platform Helper Library for Other Libraries
-License: LGPL-2.1-or-later
+License: LGPL-2.1+
Group: Development/Libraries/C and C++
Requires: glibc-devel
+Requires: %{libname} = %{version}
Requires: libgwengui-fox16-0 = %{version}
Requires: libgwengui-gtk2-0 = %{version}
Requires: libgwengui-gtk3-0 = %{version}
+%if %{with qt4}
+Requires: libgwengui-qt4-0 = %{version}
+%endif
Requires: libgwengui-qt5-0 = %{version}
-Requires: libgwenhywfar%{libversion} = %{version}

%description devel
Gwenhywfar is a base library used to provide OS abstraction functions
@@ -192,9 +209,8 @@
communication etc).

%lang_package
-
%prep
-%setup -q -n %{name}-%{_version}
+%setup -q

%build
export PATH=%{_libqt5_bindir}:$PATH
@@ -209,49 +225,63 @@
--enable-full-doc\
--with-docpath=%{_docdir}/%{name}/api \
--disable-static \
+%if %{with qt4}
+ --with-qt4-libs=%{_libdir} \
+ --with-guis="fox16 qt4 qt5 gtk2 gtk3" \
+%else
--with-guis="fox16 qt5 gtk2 gtk3" \
+%endif
--with-plugins-cfgmgr=all \
--with-pic
-%make_jobs
-make %{?_smp_mflags} srcdoc
+%__make %{?smp_mflags}
+%__make srcdoc %{?smp_mflags}

%install
%make_install
%make_install install-srcdoc
pushd %{buildroot}%{_docdir}/%{name}/api
# we don't want another 'gwenhywfar' dir below docpath
- mv %{name}/* ./
+ %__mv %{name}/* ./
rm -rf %{name}
# remove empty files
- `find -maxdepth 1 -type f -empty -print0 | xargs -0 echo rm -f`
+ `find -maxdepth 1 -type f -empty -print0 | xargs -0 echo %__rm -f`
popd
find %{buildroot} -type f -name "*.la" -delete -print
%find_lang %{name}
%fdupes %{buildroot}%{_datadir}/%{name}/apidoc
%fdupes %{buildroot}%{_libdir}/cmake

-%post -n libgwenhywfar%{libversion} -p /sbin/ldconfig
-%postun -n libgwenhywfar%{libversion} -p /sbin/ldconfig
+%post -n %{libname} -p /sbin/ldconfig
+%postun -n %{libname} -p /sbin/ldconfig
+
%post -n libgwengui-cpp0 -p /sbin/ldconfig
%postun -n libgwengui-cpp0 -p /sbin/ldconfig
+
%post -n libgwengui-gtk2-0 -p /sbin/ldconfig
%postun -n libgwengui-gtk2-0 -p /sbin/ldconfig
+
%post -n libgwengui-gtk3-0 -p /sbin/ldconfig
%postun -n libgwengui-gtk3-0 -p /sbin/ldconfig
+
+%if %{with qt4}
+%post -n libgwengui-qt4-0 -p /sbin/ldconfig
+%postun -n libgwengui-qt4-0 -p /sbin/ldconfig
+%endif
+
%post -n libgwengui-qt5-0 -p /sbin/ldconfig
%postun -n libgwengui-qt5-0 -p /sbin/ldconfig
+
%post -n libgwengui-fox16-0 -p /sbin/ldconfig
%postun -n libgwengui-fox16-0 -p /sbin/ldconfig

%files
-%license COPYING
-%doc AUTHORS NEWS README TODO
+%doc AUTHORS COPYING NEWS README TODO
%dir %{_datadir}/%{name}/
%{_datadir}/%{name}/ca-bundle.crt
%{_datadir}/%{name}/dialogs/
%dir %{_libdir}/%{name}
%dir %{_libdir}/%{name}/plugins
-%dir %{_libdir}/%{name}/plugins/%{libversion}
+%dir %{_libdir}/%{name}/plugins/60
%exclude %{_docdir}/%{name}/api

%files tools
@@ -263,10 +293,10 @@
%{_bindir}/xmlmerge
%{_datadir}/%{name}/typemaker2/

-%files -n libgwenhywfar%{libversion}-plugins
-%{_libdir}/%{name}/plugins/%{libversion}/*
+%files -n %{libname}-plugins
+%{_libdir}/%{name}/plugins/60/*

-%files -n libgwenhywfar%{libversion}
+%files -n %{libname}
%{_libdir}/lib%{name}.so.*

%files -n libgwengui-cpp0
@@ -278,6 +308,11 @@
%files -n libgwengui-gtk3-0
%{_libdir}/libgwengui-gtk3.so.*

+%if %{with qt4}
+%files -n libgwengui-qt4-0
+%{_libdir}/libgwengui-qt4.so.*
+%endif
+
%files -n libgwengui-qt5-0
%{_libdir}/libgwengui-qt5.so.*

@@ -289,17 +324,21 @@
%dir %{_datadir}/aclocal
%{_datadir}/aclocal/%{name}.m4
%doc %{_docdir}/%{name}/api/
-%{_includedir}/%{name}%{devversion}/
+%{_includedir}/%{name}4/
%{_libdir}/*.so
%{_libdir}/pkgconfig/%{name}.pc
%{_libdir}/pkgconfig/gwengui-gtk2.pc
%{_libdir}/pkgconfig/gwengui-gtk3.pc
+%if %{with qt4}
+%{_libdir}/pkgconfig/gwengui-qt4.pc
+%{_libdir}/cmake/gwengui-qt4-%{devversion}
+%endif
%{_libdir}/pkgconfig/gwengui-qt5.pc
%{_libdir}/pkgconfig/gwengui-fox16.pc
%dir %{_libdir}/cmake
-%{_libdir}/cmake/%{name}-%{devrelease}
-%{_libdir}/cmake/gwengui-cpp-%{devrelease}
-%{_libdir}/cmake/gwengui-qt5-%{devrelease}
+%{_libdir}/cmake/%{name}-%{devversion}
+%{_libdir}/cmake/gwengui-cpp-%{devversion}
+%{_libdir}/cmake/gwengui-qt5-%{devversion}

%files lang -f %{name}.lang


++++++ gwenhywfar-4.99.8beta.tar.gz -> gwenhywfar-4.20.1.tar.gz ++++++
++++ 13487 lines of diff (skipped)


< Previous Next >
This Thread