Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit python-Sphinx for openSUSE:Factory
Hello community,

here is the log from the commit of package python-Sphinx for openSUSE:Factory
checked in at 2019-04-12 09:14:08
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/python-Sphinx (Old)
and /work/SRC/openSUSE:Factory/.python-Sphinx.new.27019 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "python-Sphinx"

Fri Apr 12 09:14:08 2019 rev:54 rq:693013 version:1.8.5

Changes:
--------
--- /work/SRC/openSUSE:Factory/python-Sphinx/python-Sphinx.changes
2019-03-29 20:38:17.614666716 +0100
+++ /work/SRC/openSUSE:Factory/.python-Sphinx.new.27019/python-Sphinx.changes
2019-04-12 09:14:10.893667928 +0200
@@ -1,0 +2,10 @@
+Wed Apr 10 20:43:43 UTC 2019 - Dirk Mueller <dmueller@xxxxxxxx>
+
+- don't provide sphinx from test subpackage, it is for testing
+
+-------------------------------------------------------------------
+Wed Apr 10 07:13:28 UTC 2019 - Dirk Mueller <dmueller@xxxxxxxx>
+
+- fix tests to include latex/extmath tests
+
+-------------------------------------------------------------------

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ python-Sphinx.spec ++++++
--- /var/tmp/diff_new_pack.HAQ8dS/_old 2019-04-12 09:14:11.669668384 +0200
+++ /var/tmp/diff_new_pack.HAQ8dS/_new 2019-04-12 09:14:11.681668392 +0200
@@ -61,6 +61,7 @@
BuildArch: noarch
%if %{with test}
BuildRequires: %{python_module Sphinx = %{version}}
+BuildRequires: %{python_module Sphinx-latex = %{version}}
BuildRequires: %{python_module html5lib}
BuildRequires: %{python_module mock}
BuildRequires: %{python_module pytest}
@@ -84,9 +85,11 @@
%endif
%endif
%ifpython2
+%if ! %{with test}
Obsoletes: %{oldpython}-sphinx < %{version}
Provides: %{oldpython}-sphinx = %{version}
%endif
+%endif
%python_subpackages

%description
@@ -166,6 +169,7 @@
Requires: tex(utf8x.def)
Requires: tex(wrapfig.sty)
%if 0%{?suse_version} > 1320
+Requires: texlive-dvipng
Requires: texlive-latexmk
Requires: texlive-makeindex
Requires: tex(varwidth.sty)


< Previous Next >
This Thread
  • No further messages