Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit python-jenkins-job-builder for openSUSE:Factory
Hello community,

here is the log from the commit of package python-jenkins-job-builder for
openSUSE:Factory checked in at 2019-04-08 20:53:47
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/python-jenkins-job-builder (Old)
and /work/SRC/openSUSE:Factory/.python-jenkins-job-builder.new.3908 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "python-jenkins-job-builder"

Mon Apr 8 20:53:47 2019 rev:15 rq:692274 version:2.9.1

Changes:
--------
---
/work/SRC/openSUSE:Factory/python-jenkins-job-builder/python-jenkins-job-builder.changes
2019-02-05 11:19:01.664887007 +0100
+++
/work/SRC/openSUSE:Factory/.python-jenkins-job-builder.new.3908/python-jenkins-job-builder.changes
2019-04-08 20:53:49.202580861 +0200
@@ -1,0 +2,6 @@
+Mon Apr 8 11:30:44 UTC 2019 - Thomas Bechtold <tbechtold@xxxxxxxx>
+
+- Add 0001-Allow-pyyaml-5.patch
+ Needed for newer python-PyYAML versions
+
+-------------------------------------------------------------------

New:
----
0001-Allow-pyyaml-5.patch

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ python-jenkins-job-builder.spec ++++++
--- /var/tmp/diff_new_pack.yzNFIt/_old 2019-04-08 20:53:50.090581513 +0200
+++ /var/tmp/diff_new_pack.yzNFIt/_new 2019-04-08 20:53:50.090581513 +0200
@@ -26,6 +26,8 @@
Group: Development/Languages/Python
Url: https://github.com/openstack-ci/jenkins-job-builder
Source:
https://files.pythonhosted.org/packages/source/j/jenkins-job-builder/jenkins-job-builder-%{version}.tar.gz
+# # PATCH-FIX-UPSTREAM 0001-Allow-pyyaml-5.patch --
https://review.openstack.org/650859
+Patch0: 0001-Allow-pyyaml-5.patch
BuildRequires: %{python_module Jinja2}
BuildRequires: %{python_module fasteners}
BuildRequires: %{python_module mock}
@@ -56,6 +58,7 @@

%prep
%setup -q -n jenkins-job-builder-%{version}
+%patch0 -p1

%build
%python_build

++++++ 0001-Allow-pyyaml-5.patch ++++++
From 23079af77770f736ce340eebabfeb4714fa25d89 Mon Sep 17 00:00:00 2001
From: Thomas Bechtold <tbechtold@xxxxxxxx>
Date: Mon, 8 Apr 2019 13:29:43 +0200
Subject: [PATCH] Allow pyyaml >= 5

Current latest version is 5.1 so allow this version, too.

Change-Id: Ic349545720bf9a3d973fe863c7068d1e590732c3
---
requirements.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/requirements.txt b/requirements.txt
index b7a0ae27..8a619626 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
six>=1.9.0 # MIT
-PyYAML>=3.10.0,<4 # MIT
+PyYAML>=3.10.0,<6 # MIT
pbr>=1.8 # Apache-2.0
stevedore>=1.17.1 # Apache-2.0
python-jenkins>=0.4.15
--
2.21.0


< Previous Next >
This Thread
  • No further messages