Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit python-eliot for openSUSE:Factory
Hello community,

here is the log from the commit of package python-eliot for openSUSE:Factory
checked in at 2019-04-05 12:01:00
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/python-eliot (Old)
and /work/SRC/openSUSE:Factory/.python-eliot.new.3908 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "python-eliot"

Fri Apr 5 12:01:00 2019 rev:2 rq:690301 version:1.7.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/python-eliot/python-eliot.changes
2019-02-26 22:19:17.502132065 +0100
+++ /work/SRC/openSUSE:Factory/.python-eliot.new.3908/python-eliot.changes
2019-04-05 12:03:25.354586486 +0200
@@ -1,0 +2,25 @@
+Mon Apr 1 09:17:09 UTC 2019 - Tomáš Chvátal <tchvatal@xxxxxxxx>
+
+- Redownload archive as the upstream updated it on pypi
+
+-------------------------------------------------------------------
+Sun Mar 31 09:49:02 UTC 2019 - ecsos@xxxxxxxxxxxx
+
+- set minimum needed BuildRequires:
+ - python-hypothesis >= 3.47.0
+ - python-boltons >= 19.0.1
+
+-------------------------------------------------------------------
+Fri Mar 22 14:19:00 UTC 2019 - Tomáš Chvátal <tchvatal@xxxxxxxx>
+
+- Update to 1.7.0:
+ * Support for PyInstaller
+- Fix update alternatives
+
+-------------------------------------------------------------------
+Thu Feb 21 13:38:34 UTC 2019 - Jan Engelhardt <jengelh@xxxxxxx>
+
+- Drop duplicated summary. Generalize description.
+- Avoid name repetition in summary (rpmlint).
+
+-------------------------------------------------------------------

Old:
----
python-eliot-1.6.0.tar.gz

New:
----
python-eliot-1.7.0.tar.gz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ python-eliot.spec ++++++
--- /var/tmp/diff_new_pack.2icWUi/_old 2019-04-05 12:03:26.198586786 +0200
+++ /var/tmp/diff_new_pack.2icWUi/_new 2019-04-05 12:03:26.198586786 +0200
@@ -18,24 +18,22 @@

%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name: python-eliot
-Version: 1.6.0
+Version: 1.7.0
Release: 0
-Summary: Eliot: the logging system that tells you *why* it happened
+Summary: A logging system that tells the user why something happened
License: Apache-2.0
Group: Development/Languages/Python
URL: https://github.com/itamarst/eliot/
Source0:
https://github.com/itamarst/eliot/archive/%{version}/%{name}-%{version}.tar.gz
BuildRequires: %{python_module Sphinx}
BuildRequires: %{python_module Twisted}
-BuildRequires: %{python_module boltons}
-# extra
+BuildRequires: %{python_module boltons >= 19.0.1}
BuildRequires: %{python_module cffi >= 1.1.2}
BuildRequires: %{python_module coverage}
BuildRequires: %{python_module flake8}
-BuildRequires: %{python_module hypothesis >= 1.14.0}
+BuildRequires: %{python_module hypothesis >= 3.47.0}
BuildRequires: %{python_module pyrsistent >= 0.11.8}
BuildRequires: %{python_module pytest}
-# dev
BuildRequires: %{python_module setuptools >= 40}
BuildRequires: %{python_module six}
BuildRequires: %{python_module sphinx_rtd_theme}
@@ -45,18 +43,19 @@
BuildRequires: %{python_module zope.interface}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
-BuildArch: noarch
-Requires: python-boltons
+Requires: python-boltons >= 19.0.1
Requires: python-pyrsistent >= 0.11.8
Requires: python-six
Requires: python-zope.interface
+Requires(post): update-alternatives
+Requires(postun): update-alternatives
+BuildArch: noarch
%python_subpackages

%description
-Eliot: the logging system that tells you *why* it happened.
eliot is a Python logging system that outputs causal chains of actions:
actions can spawn other actions,
and eventually they either succeed or fail.
-The resulting logs tell you the story of what your software did: what
happened, and what caused it.
+The resulting logs tell the story of what the software did: what happened, and
what caused it.

%prep
%setup -q -n eliot-%{version}
@@ -74,6 +73,9 @@
%post
%python_install_alternative eliot-prettyprint

+%postun
+%python_uninstall_alternative eliot-prettyprint
+
%check
# skip prettyprint as it needs the binary to execute
%python_expand PYTHONPATH=%%{buildroot}%{$python_sitelib}
py.test-%{$python_bin_suffix} -v eliot/tests -k 'not prettyprint'

++++++ python-eliot-1.6.0.tar.gz -> python-eliot-1.7.0.tar.gz ++++++
++++ 3257 lines of diff (skipped)


< Previous Next >
This Thread
  • No further messages