Mailinglist Archive: opensuse-commit (1903 mails)

< Previous Next >
commit rubygem-pkg-config for openSUSE:Factory
Hello community,

here is the log from the commit of package rubygem-pkg-config for
openSUSE:Factory checked in at 2019-04-03 09:24:09
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/rubygem-pkg-config (Old)
and /work/SRC/openSUSE:Factory/.rubygem-pkg-config.new.25356 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "rubygem-pkg-config"

Wed Apr 3 09:24:09 2019 rev:19 rq:689700 version:1.3.7

Changes:
--------
--- /work/SRC/openSUSE:Factory/rubygem-pkg-config/rubygem-pkg-config.changes
2019-03-19 09:57:15.816129872 +0100
+++
/work/SRC/openSUSE:Factory/.rubygem-pkg-config.new.25356/rubygem-pkg-config.changes
2019-04-03 09:24:20.007711192 +0200
@@ -1,0 +2,17 @@
+Fri Mar 29 06:10:49 UTC 2019 - Stephan Kulow <coolo@xxxxxxxx>
+
+- updated to version 1.3.7
+ see installed NEWS
+
+ == 1.3.7 - 2019-03-17
+
+ === Improvements
+
+ * Added support for alphabet and _ only version.
+ [GitHub#17][Reported by xiejiangzhi]
+
+ === Thanks
+
+ * xiejiangzhi
+
+-------------------------------------------------------------------

Old:
----
pkg-config-1.3.6.gem

New:
----
pkg-config-1.3.7.gem

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ rubygem-pkg-config.spec ++++++
--- /var/tmp/diff_new_pack.DPn9fo/_old 2019-04-03 09:24:20.819711574 +0200
+++ /var/tmp/diff_new_pack.DPn9fo/_new 2019-04-03 09:24:20.823711576 +0200
@@ -24,7 +24,7 @@
#

Name: rubygem-pkg-config
-Version: 1.3.6
+Version: 1.3.7
Release: 0
%define mod_name pkg-config
%define mod_full_name %{mod_name}-%{version}

++++++ pkg-config-1.3.6.gem -> pkg-config-1.3.7.gem ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/NEWS new/NEWS
--- old/NEWS 2019-03-09 11:11:57.000000000 +0100
+++ new/NEWS 2019-03-17 06:46:23.000000000 +0100
@@ -1,5 +1,16 @@
= NEWS

+== 1.3.7 - 2019-03-17
+
+=== Improvements
+
+ * Added support for alphabet and _ only version.
+ [GitHub#17][Reported by xiejiangzhi]
+
+=== Thanks
+
+ * xiejiangzhi
+
== 1.3.6 - 2019-03-09

=== Improvements
Binary files old/checksums.yaml.gz and new/checksums.yaml.gz differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/lib/pkg-config/version.rb
new/lib/pkg-config/version.rb
--- old/lib/pkg-config/version.rb 2019-03-09 11:11:57.000000000 +0100
+++ new/lib/pkg-config/version.rb 2019-03-17 06:46:23.000000000 +0100
@@ -15,5 +15,5 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301
USA

module PKGConfig
- VERSION = "1.3.6"
+ VERSION = "1.3.7"
end
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/lib/pkg-config.rb new/lib/pkg-config.rb
--- old/lib/pkg-config.rb 2019-03-09 11:11:57.000000000 +0100
+++ new/lib/pkg-config.rb 2019-03-17 06:46:23.000000000 +0100
@@ -335,7 +335,7 @@

def parse_requires(requires)
return [] if requires.nil?
- requires_without_version = requires.gsub(/[<>]?=\s*[\d.]+\s*/, '')
+ requires_without_version = requires.gsub(/[<>]?=\s*[\d.a-zA-Z_-]+\s*/, '')
requires_without_version.split(/[,\s]+/)
end

diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/metadata new/metadata
--- old/metadata 2019-03-09 11:11:57.000000000 +0100
+++ new/metadata 2019-03-17 06:46:23.000000000 +0100
@@ -1,14 +1,14 @@
--- !ruby/object:Gem::Specification
name: pkg-config
version: !ruby/object:Gem::Version
- version: 1.3.6
+ version: 1.3.7
platform: ruby
authors:
- Kouhei Sutou
autorequire:
bindir: bin
cert_chain: []
-date: 2019-03-09 00:00:00.000000000 Z
+date: 2019-03-17 00:00:00.000000000 Z
dependencies:
- !ruby/object:Gem::Dependency
name: test-unit
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn'
'--exclude=.svnignore' old/test/test_pkg_config.rb new/test/test_pkg_config.rb
--- old/test/test_pkg_config.rb 2019-03-09 11:11:57.000000000 +0100
+++ new/test/test_pkg_config.rb 2019-03-17 06:46:23.000000000 +0100
@@ -148,4 +148,15 @@
ensure
$configure_args = original_configure_args
end
+
+ sub_test_case("#parse_requires") do
+ def parse_requires(requires)
+ @cairo.__send__(:parse_requires, requires)
+ end
+
+ def test_broken_version
+ assert_equal(["fribidi"],
+ parse_requires("fribidi >= fribidi_required_dep"))
+ end
+ end
end


< Previous Next >
This Thread
  • No further messages