Mailinglist Archive: opensuse-commit (1906 mails)

< Previous Next >
commit rubygem-devise for openSUSE:Factory
Hello community,

here is the log from the commit of package rubygem-devise for openSUSE:Factory
checked in at 2019-04-01 12:36:54
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/rubygem-devise (Old)
and /work/SRC/openSUSE:Factory/.rubygem-devise.new.25356 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "rubygem-devise"

Mon Apr 1 12:36:54 2019 rev:6 rq:689707 version:4.6.2

Changes:
--------
--- /work/SRC/openSUSE:Factory/rubygem-devise/rubygem-devise.changes
2018-10-25 08:21:00.803947186 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-devise.new.25356/rubygem-devise.changes
2019-04-01 12:37:01.109875526 +0200
@@ -1,0 +2,51 @@
+Fri Mar 29 05:59:12 UTC 2019 - Stephan Kulow <coolo@xxxxxxxx>
+
+- updated to version 4.6.2
+ see installed CHANGELOG.md
+
+ ### 4.6.2 - 2019-03-26
+
+ * bug fixes
+ * Revert "Set `encrypted_password` to `nil` when `password` is set to
`nil`" since it broke backward compatibility with existing applications. See
more on
https://github.com/plataformatec/devise/issues/5033#issuecomment-476386275 (by
@mracos)
+
+-------------------------------------------------------------------
+Sat Mar 2 15:11:34 UTC 2019 - Stephan Kulow <coolo@xxxxxxxx>
+
+- updated to version 4.6.1
+ see installed CHANGELOG.md
+
+ ### 4.6.1 - 2019-02-11
+
+ * bug fixes
+ * Check if `root_path` is defined with `#respond_to?` instead of
`#present` (by @tegon)
+
+ ### 4.6.0 - 2019-02-07
+
+ * enhancements
+ * Allow to skip email and password change notifications (by @iorme1)
+ * Include the use of `nil` for `allow_unconfirmed_access_for` in the docs
(by @joaumg)
+ * Ignore useless files into the `.gem` file (by @huacnlee)
+ * Explain the code that prevents enumeration attacks inside
`Devise::Strategies::DatabaseAuthenticatable` (by @tegon)
+ * Refactor the `devise_error_messages!` helper to render a partial (by
@prograhamer)
+ * Add an option (`Devise.sign_in_after_change_password`) to not
automatically sign in a user after changing a password (by @knjko)
+
+ * bug fixes
+ * Fix missing comma in Simple Form generator (by @colinross)
+ * Fix error with migration generator in Rails 6 (by @oystersauce8)
+ * Set `encrypted_password` to `nil` when `password` is set to `nil` (by
@sivagollapalli)
+ * Consider whether the request supports flash messages inside
`Devise::Controllers::Helpers#is_flashing_format?` (by @colinross)
+ * Fix typo inside `Devise::Generators::ControllersGenerator` (by
@kopylovvlad)
+ * Sanitize parameters inside
`Devise::Models::Authenticatable#find_or_initialize_with_errors` (by @rlue)
+ * `#after_database_authentication` callback was not called after
authentication on password reset (by @kanmaniselvan)
+ * Fix corner case when `#confirmation_period_valid?` was called at the
same second as `confirmation_sent_at` was set. Mostly true for date types that
only have second precisions. (by @stanhu)
+ * Fix unclosed `li` tag in `error_messages` partial (by @mracos)
+ * Fix Routes issue when devise engine is mounted in another engine on
Rails versions lower than 5.1 (by @a-barbieri)
+ * Make `#increment_failed_attempts` concurrency safe (by @tegon)
+ * Apply Test Helper fix to Rails 6.0 as well as 5.x (by @matthewrudy)
+
+
+ * deprecations
+ * The second argument of `DatabaseAuthenticatable`'s
`#update_with_password` and `#update_without_password` is deprecated and will
be removed in the next major version. It was added to support a feature
deprecated in Rails 4, so you can safely remove it from your code. (by
@ihatov08)
+ * The `DeviseHelper.devise_error_messages!` is deprecated and will be
removed in the next major version. Use the `devise/shared/error_messages`
partial instead. (by @mracos)
+
+-------------------------------------------------------------------

Old:
----
devise-4.5.0.gem

New:
----
devise-4.6.2.gem

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ rubygem-devise.spec ++++++
--- /var/tmp/diff_new_pack.mggoue/_old 2019-04-01 12:37:03.009876456 +0200
+++ /var/tmp/diff_new_pack.mggoue/_new 2019-04-01 12:37:03.013876458 +0200
@@ -1,7 +1,7 @@
#
# spec file for package rubygem-devise
#
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


@@ -24,7 +24,7 @@
#

Name: rubygem-devise
-Version: 4.5.0
+Version: 4.6.2
Release: 0
%define mod_name devise
%define mod_full_name %{mod_name}-%{version}

++++++ devise-4.5.0.gem -> devise-4.6.2.gem ++++++
++++ 13517 lines of diff (skipped)


< Previous Next >
This Thread
  • No further messages