Mailinglist Archive: opensuse-commit (1059 mails)

< Previous Next >
commit PolicyKit
  • From: root@xxxxxxxxxxxxxxx (h_root)
  • Date: Thu, 03 Jan 2008 18:04:54 +0100
  • Message-id: <20080103170455.227B2678335@xxxxxxxxxxxxxxx>

Hello community,

here is the log from the commit of package PolicyKit
checked in at Thu Jan 3 18:04:54 CET 2008.

--------
--- PolicyKit/PolicyKit.changes 2007-10-17 14:56:18.000000000 +0200
+++ /mounts/work_src_done/STABLE/PolicyKit/PolicyKit.changes 2008-01-02
14:00:13.448906000 +0100
@@ -1,0 +2,34 @@
+Wed Jan 2 13:32:32 CET 2008 - kay.sievers@xxxxxxxxxx
+
+- add Recommend: PolicyKit-doc package
+- this sets the expected permissions, if the updated
+ /etc/permissions.* (nbz#295341) is not available at installation time:
+ # chown root:polkituser /usr/lib64/PolicyKit/polkit-*
+ # chmod 2755 /usr/lib64/PolicyKit/polkit-*
+ # chmod 4755 /usr/lib64/PolicyKit/polkit-grant-helper-pam
+
+-------------------------------------------------------------------
+Thu Dec 20 16:32:39 CET 2007 - kay.sievers@xxxxxxxxxx
+
+- updated to v0.7
+ - All code is now licensed under the MIT/X11 license
+ - libpolkit and libpolkit-dbus no longer depends on libglib.
+ - Unit test framework and coverage reporting. As of this release, 64%
+ of the codebase is currently tested during 'make check'.
+ - New system D-Bus service (activated on demand) providing the major
+ functionality of libpolkit.so from a mechanism point of view. This
+ is useful for chroot(2)'ed services like Avahi.
+ - A class for tracking D-Bus connections to minimize the amount
+ of IPC necessary. Useful for long running daemons.
+ - Pluggable authorization database backend.
+ - New API for interacting with the authorization database
+ - A very simple convenience API useful for (legacy) commandline tools.
+ - A way to specify that an implicit authorization can be one-shot
+ only.
+ - Vendor name, site and icon support in .policy files.
+ - Improved documentation.
+ - Negative authorizations.
+ - Bash completions for all command line tools.
+- needs /etc/permissions.* update (nbz#295341)
+
+-------------------------------------------------------------------
PolicyKit-doc.changes: same change

Old:
----
PolicyKit-0.6.tar.bz2

New:
----
PolicyKit-0.7.tar.bz2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ PolicyKit-doc.spec ++++++
--- /var/tmp/diff_new_pack.l31362/_old 2008-01-03 18:03:56.000000000 +0100
+++ /var/tmp/diff_new_pack.l31362/_new 2008-01-03 18:03:56.000000000 +0100
@@ -1,7 +1,7 @@
#
-# spec file for package PolicyKit-doc (Version 0.6)
+# spec file for package PolicyKit-doc (Version 0.7)
#
-# Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
@@ -12,7 +12,7 @@

Name: PolicyKit-doc
%define build_doc 1
-BuildRequires: dbus-1-glib-devel fdupes glib2-devel pkg-config
+BuildRequires: dbus-1-glib-devel fdupes glib2-devel intltool pkg-config
BuildRequires: libexpat-devel pam-devel
%if %build_doc
BuildRequires: gtk-doc xmlto
@@ -21,10 +21,10 @@
PreReq: permissions /usr/sbin/groupadd /usr/sbin/useradd
%endif
Url: http://www.freedesktop.org/wiki/Software/hal
-License: GPL v2 only
+License: X11/MIT
Group: Documentation/Other
-Version: 0.6
-Release: 1
+Version: 0.7
+Release: 2
AutoReqProv: on
Summary: Documentation for PolicyKit
BuildRoot: %{_tmppath}/%{name}-%{version}-build
@@ -32,11 +32,14 @@
Requires: PolicyKit = %{version}
%else
Requires: ConsoleKit
+Recommends: PolicyKit-doc
%endif
Source: PolicyKit-%{version}.tar.bz2

%description
-This package contains the documentation for PolicyKit.
+PolicyKit is a toolkit for defining and handling authorizations. It is
+used for allowing unprivileged processes to speak to privileged
+processes.



@@ -45,6 +48,7 @@
David Zeuthen <davidz@xxxxxxxxxx>

%if !%build_doc
+
%package -n PolicyKit-devel
Summary: Development files for PolicyKit
Group: Development/Libraries/Other
@@ -53,6 +57,10 @@
%description -n PolicyKit-devel
This package contains the development files for PolicyKit.

+PolicyKit is a toolkit for defining and handling authorizations. It is
+used for allowing unprivileged processes to speak to privileged
+processes.
+


Authors:
@@ -60,11 +68,11 @@
David Zeuthen <davidz@xxxxxxxxxx>

%endif
+
%prep
%setup -q -n PolicyKit-%{version}

%build
-autoreconf -fi
%configure \
--libexecdir=%{_libexecdir}/PolicyKit \
%if %build_doc
@@ -83,14 +91,16 @@
%endif
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
-chmod 0755 $RPM_BUILD_ROOT%{_libexecdir}/PolicyKit/polkit-grant-helper
%fdupes -s $RPM_BUILD_ROOT
%if %build_doc
rm -rf $RPM_BUILD_ROOT/%{_bindir}
rm -rf $RPM_BUILD_ROOT/%{_libdir}
rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/PolicyKit
+rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1
+rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/profile.d
rm -rf $RPM_BUILD_ROOT/%{_libexecdir}
rm -rf $RPM_BUILD_ROOT/%{_datadir}/PolicyKit
+rm -rf $RPM_BUILD_ROOT/%{_datadir}/dbus-1
rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/polkit
rm -rf $RPM_BUILD_ROOT/%{_includedir}
rm -rf $RPM_BUILD_ROOT/%{_localstatedir}
@@ -122,8 +132,12 @@
/sbin/ldconfig
%run_permissions
%verifyscript
-%verify_permissions -e %{_libexecdir}/polkit-grant-helper
-%verify_permissions -e %{_libexecdir}/polkit-grant-helper-pam
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-grant-helper
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-grant-helper-pam
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-set-default-helper
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-read-auth-helper
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-revoke-helper
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-explicit-grant-helper

%postun
/sbin/ldconfig
@@ -149,21 +163,62 @@
%config(noreplace) %{_sysconfdir}/PolicyKit/PolicyKit.conf
%config(noreplace) %{_sysconfdir}/pam.d/polkit
%dir %{_libexecdir}/PolicyKit
+%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-set-default-helper
+%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-read-auth-helper
+%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-revoke-helper
+%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-explicit-grant-helper
%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-grant-helper
-%verify(not mode) %attr(0755,root,root)
%{_libexecdir}/PolicyKit/polkit-grant-helper-pam
-%attr(0775,polkituser,polkituser) %dir %{_localstatedir}/run/PolicyKit
-%attr(0775,polkituser,polkituser) %dir %{_localstatedir}/lib/PolicyKit
+%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-grant-helper-pam
+%attr(0770,polkituser,polkituser) %dir %{_localstatedir}/run/PolicyKit
+%attr(0770,polkituser,polkituser) %dir %{_localstatedir}/lib/PolicyKit
+%attr(0775,polkituser,polkituser) %dir %{_localstatedir}/lib/PolicyKit-public
+%attr(0775,root,polkituser) %{_localstatedir}/lib/misc/PolicyKit.reload
%dir %{_datadir}/PolicyKit
%dir %{_datadir}/PolicyKit/policy
+%{_datadir}/PolicyKit/policy/org.freedesktop.policykit.policy
%{_datadir}/PolicyKit/config.dtd
+%{_datadir}/dbus-1/system-services/org.freedesktop.PolicyKit.service
+%{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit.conf
+%{_libexecdir}/PolicyKit/polkitd
+%{_sysconfdir}/profile.d/polkit-bash-completion.sh

%files -n PolicyKit-devel
%defattr(-,root,root)
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*
%{_includedir}/*
+%{_datadir}/dbus-1/interfaces/org.freedesktop.PolicyKit.AuthenticationAgent.xml
%endif
+
%changelog
+* Wed Jan 02 2008 - kay.sievers@xxxxxxxxxx
+- add Recommend: PolicyKit-doc package
+- this sets the expected permissions, if the updated
+ /etc/permissions.* (nbz#295341) is not available at installation time:
+ [#] chown root:polkituser /usr/lib64/PolicyKit/polkit-*
+ [#] chmod 2755 /usr/lib64/PolicyKit/polkit-*
+ [#] chmod 4755 /usr/lib64/PolicyKit/polkit-grant-helper-pam
+* Thu Dec 20 2007 - kay.sievers@xxxxxxxxxx
+- updated to v0.7
+ - All code is now licensed under the MIT/X11 license
+ - libpolkit and libpolkit-dbus no longer depends on libglib.
+ - Unit test framework and coverage reporting. As of this release, 64%
+ of the codebase is currently tested during 'make check'.
+ - New system D-Bus service (activated on demand) providing the major
+ functionality of libpolkit.so from a mechanism point of view. This
+ is useful for chroot(2)'ed services like Avahi.
+ - A class for tracking D-Bus connections to minimize the amount
+ of IPC necessary. Useful for long running daemons.
+ - Pluggable authorization database backend.
+ - New API for interacting with the authorization database
+ - A very simple convenience API useful for (legacy) commandline tools.
+ - A way to specify that an implicit authorization can be one-shot
+ only.
+ - Vendor name, site and icon support in .policy files.
+ - Improved documentation.
+ - Negative authorizations.
+ - Bash completions for all command line tools.
+- needs /etc/permissions.* update (nbz#295341)
* Wed Oct 17 2007 - dkukawka@xxxxxxx
- updated to v0.6:
- This is the fourth release of PolicyKit. There are no major

++++++ PolicyKit.spec ++++++
--- /var/tmp/diff_new_pack.l31362/_old 2008-01-03 18:03:56.000000000 +0100
+++ /var/tmp/diff_new_pack.l31362/_new 2008-01-03 18:03:56.000000000 +0100
@@ -1,7 +1,7 @@
#
-# spec file for package PolicyKit (Version 0.6)
+# spec file for package PolicyKit (Version 0.7)
#
-# Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
@@ -12,7 +12,7 @@

Name: PolicyKit
%define build_doc 0
-BuildRequires: dbus-1-glib-devel fdupes glib2-devel pkg-config
+BuildRequires: dbus-1-glib-devel fdupes glib2-devel intltool pkg-config
BuildRequires: libexpat-devel pam-devel
%if %build_doc
BuildRequires: gtk-doc xmlto
@@ -21,23 +21,25 @@
PreReq: permissions /usr/sbin/groupadd /usr/sbin/useradd
%endif
Url: http://www.freedesktop.org/wiki/Software/hal
-License: GPL v2 only
+License: X11/MIT
Group: System/Libraries
-Version: 0.6
-Release: 1
+Version: 0.7
+Release: 2
AutoReqProv: on
-Summary: PolicyKit
+Summary: Authorization Toolkit
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if %build_doc
Requires: PolicyKit = %{version}
%else
Requires: ConsoleKit
+Recommends: PolicyKit-doc
%endif
Source: PolicyKit-%{version}.tar.bz2

%description
-PolicyKit is a toolkit for defining and handling the policy that allows
-unprivileged processes to speak to privileged processes.
+PolicyKit is a toolkit for defining and handling authorizations. It is
+used for allowing unprivileged processes to speak to privileged
+processes.



@@ -46,6 +48,7 @@
David Zeuthen <davidz@xxxxxxxxxx>

%if !%build_doc
+
%package -n PolicyKit-devel
Summary: Development files for PolicyKit
Group: Development/Libraries/Other
@@ -54,6 +57,10 @@
%description -n PolicyKit-devel
This package contains the development files for PolicyKit.

+PolicyKit is a toolkit for defining and handling authorizations. It is
+used for allowing unprivileged processes to speak to privileged
+processes.
+


Authors:
@@ -61,11 +68,11 @@
David Zeuthen <davidz@xxxxxxxxxx>

%endif
+
%prep
%setup -q -n PolicyKit-%{version}

%build
-autoreconf -fi
%configure \
--libexecdir=%{_libexecdir}/PolicyKit \
%if %build_doc
@@ -84,14 +91,16 @@
%endif
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
-chmod 0755 $RPM_BUILD_ROOT%{_libexecdir}/PolicyKit/polkit-grant-helper
%fdupes -s $RPM_BUILD_ROOT
%if %build_doc
rm -rf $RPM_BUILD_ROOT/%{_bindir}
rm -rf $RPM_BUILD_ROOT/%{_libdir}
rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/PolicyKit
+rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1
+rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/profile.d
rm -rf $RPM_BUILD_ROOT/%{_libexecdir}
rm -rf $RPM_BUILD_ROOT/%{_datadir}/PolicyKit
+rm -rf $RPM_BUILD_ROOT/%{_datadir}/dbus-1
rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/polkit
rm -rf $RPM_BUILD_ROOT/%{_includedir}
rm -rf $RPM_BUILD_ROOT/%{_localstatedir}
@@ -123,8 +132,12 @@
/sbin/ldconfig
%run_permissions
%verifyscript
-%verify_permissions -e %{_libexecdir}/polkit-grant-helper
-%verify_permissions -e %{_libexecdir}/polkit-grant-helper-pam
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-grant-helper
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-grant-helper-pam
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-set-default-helper
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-read-auth-helper
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-revoke-helper
+%verify_permissions -e %{_libexecdir}/PolicyKit/polkit-explicit-grant-helper

%postun
/sbin/ldconfig
@@ -150,21 +163,62 @@
%config(noreplace) %{_sysconfdir}/PolicyKit/PolicyKit.conf
%config(noreplace) %{_sysconfdir}/pam.d/polkit
%dir %{_libexecdir}/PolicyKit
+%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-set-default-helper
+%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-read-auth-helper
+%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-revoke-helper
+%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-explicit-grant-helper
%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-grant-helper
-%verify(not mode) %attr(0755,root,root)
%{_libexecdir}/PolicyKit/polkit-grant-helper-pam
-%attr(0775,polkituser,polkituser) %dir %{_localstatedir}/run/PolicyKit
-%attr(0775,polkituser,polkituser) %dir %{_localstatedir}/lib/PolicyKit
+%verify(not mode) %attr(0755,root,polkituser)
%{_libexecdir}/PolicyKit/polkit-grant-helper-pam
+%attr(0770,polkituser,polkituser) %dir %{_localstatedir}/run/PolicyKit
+%attr(0770,polkituser,polkituser) %dir %{_localstatedir}/lib/PolicyKit
+%attr(0775,polkituser,polkituser) %dir %{_localstatedir}/lib/PolicyKit-public
+%attr(0775,root,polkituser) %{_localstatedir}/lib/misc/PolicyKit.reload
%dir %{_datadir}/PolicyKit
%dir %{_datadir}/PolicyKit/policy
+%{_datadir}/PolicyKit/policy/org.freedesktop.policykit.policy
%{_datadir}/PolicyKit/config.dtd
+%{_datadir}/dbus-1/system-services/org.freedesktop.PolicyKit.service
+%{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit.conf
+%{_libexecdir}/PolicyKit/polkitd
+%{_sysconfdir}/profile.d/polkit-bash-completion.sh

%files -n PolicyKit-devel
%defattr(-,root,root)
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*
%{_includedir}/*
+%{_datadir}/dbus-1/interfaces/org.freedesktop.PolicyKit.AuthenticationAgent.xml
%endif
+
%changelog
+* Wed Jan 02 2008 - kay.sievers@xxxxxxxxxx
+- add Recommend: PolicyKit-doc package
+- this sets the expected permissions, if the updated
+ /etc/permissions.* (nbz#295341) is not available at installation time:
+ [#] chown root:polkituser /usr/lib64/PolicyKit/polkit-*
+ [#] chmod 2755 /usr/lib64/PolicyKit/polkit-*
+ [#] chmod 4755 /usr/lib64/PolicyKit/polkit-grant-helper-pam
+* Thu Dec 20 2007 - kay.sievers@xxxxxxxxxx
+- updated to v0.7
+ - All code is now licensed under the MIT/X11 license
+ - libpolkit and libpolkit-dbus no longer depends on libglib.
+ - Unit test framework and coverage reporting. As of this release, 64%
+ of the codebase is currently tested during 'make check'.
+ - New system D-Bus service (activated on demand) providing the major
+ functionality of libpolkit.so from a mechanism point of view. This
+ is useful for chroot(2)'ed services like Avahi.
+ - A class for tracking D-Bus connections to minimize the amount
+ of IPC necessary. Useful for long running daemons.
+ - Pluggable authorization database backend.
+ - New API for interacting with the authorization database
+ - A very simple convenience API useful for (legacy) commandline tools.
+ - A way to specify that an implicit authorization can be one-shot
+ only.
+ - Vendor name, site and icon support in .policy files.
+ - Improved documentation.
+ - Negative authorizations.
+ - Bash completions for all command line tools.
+- needs /etc/permissions.* update (nbz#295341)
* Wed Oct 17 2007 - dkukawka@xxxxxxx
- updated to v0.6:
- This is the fourth release of PolicyKit. There are no major

++++++ PolicyKit-0.6.tar.bz2 -> PolicyKit-0.7.tar.bz2 ++++++
++++ 85583 lines of diff (skipped)



++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Remember to have fun...

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-commit+help@xxxxxxxxxxxx

< Previous Next >
This Thread