Mailinglist Archive: opensuse-commit (2092 mails)

< Previous Next >
commit gtk-sharp2
  • From: root@xxxxxxxxxxxxxxx (h_root)
  • Date: Fri, 03 Aug 2007 21:37:12 +0200
  • Message-id: <20070803193712.E0D88678180@xxxxxxxxxxxxxxx>

Hello community,

here is the log from the commit of package gtk-sharp2
checked in at Fri Aug 3 21:37:12 CEST 2007.

--------
--- GNOME/gtk-sharp2/gtk-sharp2.changes 2007-07-15 10:07:23.000000000 +0200
+++ /mounts/work_src_done/STABLE/gtk-sharp2/gtk-sharp2.changes  2007-08-03 21:07:47.626430000 +0200
@@ -1,0 +2,9 @@
+Fri Aug  3 20:49:10 CEST 2007 - wberrier@xxxxxxx
+
+- Update to bigfix release: 2.10.2
+ -Bugfixes: bugzilla.ximian.com:
+  -82287, 78524, 79214, 82037, 82098, 82115
+- Remove fix_callback_code_generator.patch, as it's been fixed in 
+  2.10.2
+
+-------------------------------------------------------------------

Old:
----
  fix_callback_code_generator.patch
  gtk-sharp-2.10.1.tar.bz2

New:
----
  gtk-sharp-2.10.2.tar.bz2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ gtk-sharp2.spec ++++++
--- /var/tmp/diff_new_pack.l15705/_old  2007-08-03 21:36:29.000000000 +0200
+++ /var/tmp/diff_new_pack.l15705/_new  2007-08-03 21:36:29.000000000 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package gtk-sharp2 (Version 0)
+# spec file for package gtk-sharp2 (Version 2.10.2)
 #
 # Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # This file and all modifications and additions to the pristine
@@ -25,15 +25,14 @@
 Patch3:         gtk-sharp-find_gtkhtml_ver.patch
 Patch4:         gtk-sharp-fix_vte_so_version.patch
 Patch5:         gnome-sharp-revert_unportable_relocatable.patch
-Patch6:         fix_callback_code_generator.patch
 %define old_version 2.4.3
 %define new_version 2.8.3
-%define new_split_version 2.10.1
+%define new_split_version 2.10.2
 %define platform_desktop_split 0
 #####  suse  ####
 %if 0%{?suse_version}
 ## which gtk version ###
-%if %suse_version > 930
+%if %suse_version >= 1000
 %define _version %new_version
 %else
 %define _version %old_version
@@ -44,8 +43,7 @@
 %endif
 # Not needed with rpm .config dep search
 #%define gtkhtml_requires gtkhtml2
-%define new_suse_buildrequires libgnomedb-devel librsvg-devel mono-devel vte-devel gnome-panel-devel  monodoc-core update-desktop-files
-%define old_suse_buildrequires libgnomedb-devel librsvg-devel mono-devel vte-devel pkgconfig pango-devel gtk2-devel libxml2-devel libart_lgpl-devel libgnomecanvas-devel libgnomeui libgnomeui-devel  libglade2-devel libgda-devel libxslt-devel libgsf-devel libgnomeprint-devel libgnomeprintui-devel popt-devel esound-devel freetype2-devel libbonoboui libgnome gnome-vfs2 libgnomeprint libgnomeprintui monodoc-core gnome-panel-devel update-desktop-files
+%define new_suse_buildrequires librsvg-devel mono-devel vte-devel gnome-panel-devel  monodoc-core update-desktop-files
 %if %suse_version >= 1020
 BuildRequires:  %{new_suse_buildrequires} gtkhtml2-devel
 %endif
@@ -62,11 +60,6 @@
 # vte for .config resolution...
 BuildRequires:  %{new_suse_buildrequires} gtkhtml2-devel vte
 %endif
-%if %suse_version == 930
-BuildRequires:  %{old_suse_buildrequires}
-BuildRequires:  gnome-keyring-devel libjpeg-devel
-BuildRequires:  gtkhtml2-devel
-%endif
 %endif
 #################
 ####  fedora  ####
@@ -79,13 +72,13 @@
 %define _version %new_version
 %endif
 # All fedora distros (5 and 6) have the same names, requirements
-BuildRequires:  gnome-panel-devel gtkhtml3-devel libgnomedb-devel libgnomeprintui22-devel librsvg2-devel mono-devel monodoc-core vte-devel
+BuildRequires:  gnome-panel-devel gtkhtml3-devel libgnomeprintui22-devel librsvg2-devel mono-devel monodoc-core vte-devel
 # Not needed with rpm .config dep search
 #%define gtkhtml_requires gtkhtml2
 %endif
 #################
-# Need to put this stuff down here after Version: gets defined
-Version:        %_version
+# Need to put this stuff down here after Version:      2.10.2
+Version:        2.10.2
 Release:        1
 Source:         %{_name}-%{version}.tar.bz2
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
@@ -110,7 +103,9 @@
 %package -n gtk-sharp2-doc
 Summary:        Monodoc documentation for gtk-sharp2
 Group:          System/GUI/GNOME
-Requires:       mono-tools
+# Disable this for now, as it's a circular dep
+#  Works ok in autobuild/buildservice, not so well in monobuild
+#Requires:       mono-tools
 
 %description -n gtk-sharp2-doc
 This package contains the gtk-sharp2 documentation for monodoc.
@@ -247,7 +242,6 @@
 %patch4 -p1
 %patch5 -p1
 %endif
-%patch6 -p0
 
 %build
 %{?env_options}
@@ -389,6 +383,12 @@
 %endif
 
 %changelog
+* Fri Aug 03 2007 - wberrier@xxxxxxx
+- Update to bigfix release: 2.10.2
+ -Bugfixes: bugzilla.ximian.com:
+  -82287, 78524, 79214, 82037, 82098, 82115
+- Remove fix_callback_code_generator.patch, as it's been fixed in
+  2.10.2
 * Sun Jul 15 2007 - aj@xxxxxxx
 - Add fix_callback_code_generator.patch to fix gapi's code
   generator for callbacks with out parameters (fixes gmime-sharp).

++++++ gtk-sharp-2.10.1.tar.bz2 -> gtk-sharp-2.10.2.tar.bz2 ++++++
++++ 2417 lines of diff (skipped)


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Remember to have fun...

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-commit+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages