Mailinglist Archive: opensuse-buildservice (46 mails)

< Previous Next >
[opensuse-buildservice] Debian Testing & Unstable: "unresolvable: have choice for libsystemd0 needed by libdbus-1-3: libelogind0 libsystemd0"
Hello,

I am packaging OpenCBM:
https://build.opensuse.org/package/show/home:strik/OpenCBM

I have a problem with the targets "Debian Testing" and "Debian stable".
These do not compile, because

"unresolvable: have choice for libsystemd0 needed by libdbus-1-3: libelogind0
libsystemd0"

Having a look into the sources for libelogind0 on Debian, I see that it
also provided libsystemd0.

Now, how can I force the installation of one of them? I do not rely on
either them (at least, not directly, and not that I know of).

I tried to add "libsystemd0", then "systemd", then "libelogind0" as
build-depends, because I hoped it would force the one or the other
solution. However, this problem persists.

Does anyone have an idea what is going on? I assume it has to do with my
build-depends, because my other projects cc65 and xa65 do not exhibit
this problem with the same targets.

I am out of ideas here.

Regards
Spiro.

--
Spiro R. Trikaliotis
http://spiro.trikaliotis.net/
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups