Mailinglist Archive: opensuse-buildservice (64 mails)

< Previous Next >
[opensuse-buildservice] DoD not working for Leap 15.2
Hello all,

we're running a private OBS instance (2.9 on x86_64).

As openSUSE Leap 15.2 is getting closer to release we of course want to make
sure our
software works with it.

I therefore tried adding a simple DoD repository which I configured as follows:

--- snip ---
<project name="openSUSE.org:Leap:15.2">
<title>openSUSE Leap 15.2 OSS (DoD)</title>
[...]
<build>
<disable arch="x86_64" repository="standard"/>
</build>
<publish>
<disable/>
</publish>
<useforbuild>
<disable arch="x86_64" repository="standard"/>
</useforbuild>
<repository name="standard">
<download arch="x86_64"
url="http://download.opensuse.org/distribution/leap/15.2/repo/oss/";
repotype="rpmmd">
<archfilter>{}</archfilter>
<pubkey>{}</pubkey>
</download>
<arch>x86_64</arch>
</repository>
</project>
--- snap ---

I also copied the PRJCONF for openSUSE:Leap:15.2 from https://api.opensuse.org
into
the local project.


It's basically a 1:1 copy from the 15.1 case where it works just fine.



But if I enable this new repo for a basic project OBS tells me "nothing provides
rpm-build, nothing provides gcc-PIE".

This obviously isn't true because there is
http://download.opensuse.org/distribution/leap/15.2/repo/oss/x86_64/rpm-build-4.14.1-lp152.15.23.x86_64.rpm


I started looking through the logs in /srv/obs/log (and /srv/www/obs/api/log)
but
couldn't find a clue.


What am I missing or where could I continue to debug this?


Thanks a lot and regards -- Till
--
Dipl.-Inform. Till Dörges doerges@xxxxxxxxxxxx
PRESENSE Technologies GmbH Nagelsweg 41, D-20097 HH
Geschäftsführer/Managing Directors AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander USt-IdNr.: DE263765024
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation