Mailinglist Archive: opensuse-buildservice (88 mails)

< Previous Next >
Re: [opensuse-buildservice] Issues with python3-beautifulsoup4
  • From: Neal Gompa <ngompa13@xxxxxxxxx>
  • Date: Tue, 4 Feb 2020 09:34:39 -0500
  • Message-id: <CAEg-Je8sQJnOXmCF_QbH5qbs0xzP=b-=5M_Az9y06Ns0--tBsw@mail.gmail.com>
On Fri, Jan 31, 2020 at 7:49 AM Hamish MB <hamishmb@xxxxxxxxxx> wrote:

Thanks, but unfortunately this doesn't seem to be the case for me:

rpm -q --provides python3-beautifulsoup4 gives the output:

python-beautifulsoup4 = 4.8.1-1.fc31
python3-beautifulsoup4 = 4.8.1-1.fc31
python3.7dist(beautifulsoup4) = 4.8.1
python3dist(beautifulsoup4) = 4.8.1

And my package won't install because python3.7dist(bs4) is required and
can't be found. Do I need to install another package or something?


If your python metadata says "bs4", that's wrong. It needs to be fixed
to indicate beautifulsoup4. That's what PyPI has it as:
https://pypi.org/project/beautifulsoup4/




--
真実はいつも一つ!/ Always, there's only one truth!
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >