Mailinglist Archive: opensuse-buildservice (95 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: Build issues with Ubuntu 17.04 and 17.10
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Wed, 22 Jan 2020 11:35:40 +0100
  • Message-id: <1716796.trvjJ4NIFD@linux-ywca>
On Mittwoch, 22. Januar 2020, 11:34:05 CET Dirk Stöcker wrote:
On Wed, 22 Jan 2020, Ondrej Musil wrote:

Just to be clear, I'm not an OBS dev, but I took a look at this today.

The way that the repos work for Ubuntu for example in OBS is that they
are essentially just a link to the official distro repositories. And
since Ubuntu 17.04 and 17.10 have reached end of support, their
repositories have actually been removed. That's why you get errors
when OBS is trying to download the packages.

That cannot be the real situation. The download links are correct and the
links point to correct Ubuntu repositories, but the repositories don't
contain the software versions which are requested, but other versions.

It is ... artful and zesty have been removed on Ubuntu side. Check yourself:

http://archive.ubuntu.com/ubuntu/dists/

But there also should be a two step process where files are downloaded
from API when not available in the download directories. That also seems
not to work.

More info here: https://ubuntuforums.org/showthread.php?t=2382832
It's about 17.04, but I have no doubt the situation is the same for 17.10.

Is there any OBS operator here reading?

Could this please be fixed. To me it seems the requested software versions
simply aren't in sync with the reality.

Ciao



--

Adrian Schroeter <adrian@xxxxxxx>
Build Infrastructure Project Manager

SUSE Software Solutions Germany GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
(HRB 247165, AG München), Geschäftsführer: Felix Imendörffer




--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups