Mailinglist Archive: opensuse-buildservice (95 mails)

< Previous Next >
[opensuse-buildservice] Cannot create new project in self-hosted OBS 2.11
Hello everyone,

I cannot create a new project in our OBS instance via the web UI. When
I try it, it just shows a page with 500: Internal Server Error after
sending the request. This used to work just fine before.

The only mention about it in the logs I could found is this in
/srv/obs/log/src_server.log:
2020-01-08 06:58:52: [2461] GET (192.168.20.190)
/source/abcde/_project/_history?deleted=1

And then in the /srv/www/obs/api/log/apache_access.log:
192.168.214.3 - - [08/Jan/2020:06:58:44 +0000] "GET /project/new
HTTP/1.1" 200 2877
192.168.214.3 - - [08/Jan/2020:06:58:52 +0000] "POST /project/create
HTTP/1.1" 500 4322

And some error in /srv/www/obs/api/log/production.log:
https://gist.github.com/omusil24/aafe398bde1acd4bc4c20333d2dd7dd1

The system is a VM made using the OBS 2.10 Appliance iso, running
OpenSuse 15.1. I updated the whole system just yesterday, so OBS
version is 2.11~alpha.20200106T110100.2104ff17ec-lp151.9451.1. But it
didn't work even before the update, when there was version
2.11~alpha.20191204T172817.a980c45881-lp151.9306.2.

Also, I noticed some errors about SSL certs in apache_error.log, that
might be related to this:
[Wed Jan 08 06:47:58.856442 2020] [ssl:warn] [pid 1773] AH01909:
api:443:0 server certificate does NOT include an ID which matches the
server name

I believe I set up the correct address everywhere in config though. Am
I supposed to run some special rake task or something like that? I
tried running the following, but I don't know if that did anything
useful: RAILS_ENV="production" rake writeconfiguration
And I also restarted the VM several times after changing the config files.

Can anyone help me with this?

Thank you, and best regards.

Ondrej M.
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups