Mailinglist Archive: opensuse-buildservice (87 mails)

< Previous Next >
[opensuse-buildservice] Re: All Debian testing/unstable builds are failing: Nothing provides libperl5.28
  • From: Harald Welte <laforge@xxxxxxxxxxxx>
  • Date: Tue, 15 Oct 2019 13:35:42 +0200
  • Message-id: <20191015113542.GG3578@nataraja>
I tried to debug this further...

On Tue, Oct 15, 2019 at 12:00:18PM +0200, Harald Welte wrote:
all of the projects we build in network:osmocom:latest /
network:osmocom:nightly
are failing for both Debian Unstable and Testing. All seem to somehow depend
on libperl5.28. This must be some implicit dependency of some other package
we depend on, as we're not using perl from Osmocom projects, and don't have
any
related Depends in debian/control.

Does anyone else observe this problem?

FYI: I have just tested the following:
* create a new lxc container with debian sid (unstable)
* install the build dependencies and git
* git clone git://git.osmocom.org/libosmocore.git
* dpkg-buildpackage

And it works just fine without that mysterious libperl5.28 dependency/problem.

So it appears to be a problem that doesn't appear in upstream Debian but
is specific to OBS.

Regards,
Harald

--
- Harald Welte <laforge@xxxxxxxxxxxx> http://laforge.gnumonks.org/
============================================================================
"Privacy in residential applications is a desirable marketing option."
(ETSI EN 300 175-7 Ch. A6)
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References