Mailinglist Archive: opensuse-buildservice (144 mails)

< Previous Next >
Re: [opensuse-buildservice] Error "Version is invalid" for JeOS 15 and 15SP1
Hi,

Thanks for the confirmation, I will ping the kiwi people then : ).

Regards,
--
Vincent Moutoussamy
SUSE Beta Program, JeOS and SDK Project Manager

On 11 Sep 2019, at 14:08, Adrian Schröter <adrian@xxxxxxx> wrote:

On Mittwoch, 11. September 2019, 13:08:30 CEST Vincent Moutoussamy wrote:
Hi there,

When selecting "SLE 15 JeOS and SLE 15 SP1 JeOS” from
https://build.opensuse.org/image_templates
and trying to “create
appliance”, I get the following error message:

Kiwi File 'JeOS.kiwi' has errors:

• Preferences:

• Version is invalid


on page like:
https://build.opensuse.org/package/view_file/home:gameboy974:branches:SUSE:
Templates:Images:SLE-15-SP1/
my-kiwi-templates-SLES15-JeOS/JeOS.kiwi?expand=1

I think this is because the kiwi file contains the following, instead of
15.0.0:
<preferences profiles="kvm-and-xen">
<version>15.0</version>

At least it works for openSUSE and their kiwi files contains:
<preferences profiles="kvm-and-xen">
<version>15.1.0</version>

So my question is it really a hard requirement to have version as X.Y.Z
instead
of X.Y or is this a bug?

this used to be a hard requirement of kiwi, but it does not exist anymore in
newer versions.

(has nothing to do with OBS btw)

--

Adrian Schroeter <adrian@xxxxxxx>
Build Infrastructure Project Manager

SUSE Software Solutions Germany GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
(HRB 247165, AG München), Geschäftsführer: Felix Imendörffer




--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx



N�����r��y隊Z)z{.����Wlz��qﮞ˛���m�)z{.��+�:�{Zr�az�'z��j)h����Ǜ�)]����Ǿ�
ޮ�^�ˬz��
< Previous Next >