Mailinglist Archive: opensuse-buildservice (144 mails)

< Previous Next >
Re: [opensuse-buildservice] leap 15.0 builder problem?
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Tue, 03 Sep 2019 18:17:05 +0200
  • Message-id: <14142949.T8fuLU9Eya@linux-ywca>
On Dienstag, 3. September 2019, 17:52:27 CEST Peter Czanik wrote:
Hi,

While trying to upgrade syslog-ng in Base:system I ran into a strange
problem. Builds for openSUSE Leap 15.0 x86_64 fails, but with an error
message, which does not seem to be related to syslog-ng.spec:

that is a breakage in Base:System, a

Preinstall: libreadline8

should fix it, but it is done only for SLE_15 repo there atm.



[ 9s] booting kvm...
[ 9s] ### VM INTERACTION START ###
[ 9s] /usr/bin/qemu-kvm -nodefaults -no-reboot -nographic -vga none -cpu
host -object rng-random,filename=/dev/random,id=rng0 -device
virtio-rng-pci,rng=rng0 -runas qemu -net none -kernel
/var/cache/obs/worker/root_1/.mount/boot/kernel -initrd
/var/cache/obs/worker/root_1/.mount/boot/initrd -append
root=/dev/disk/by-id/virtio-0 rootfstype=ext3
rootflags=data=writeback,nobarrier,commit=150,noatime
ext4.allow_unsupported=1 kpti=off pti=off spectre_v2=off panic=1 quiet
no-kvmclock elevator=noop nmi_watchdog=0 rw rd.driver.pre=binfmt_misc
console=ttyS0 init=/.build/build -m 8192 -drive
file=/var/cache/obs/worker/root_1/root,format=raw,if=none,id=disk,cache=uns
afe -device virtio-blk-pci,drive=disk,serial=0 -drive
file=/var/cache/obs/worker/root_1/swap,format=raw,if=none,id=swap,cache=uns
afe -device virtio-blk-pci,drive=swap,serial=1 -serial stdio -chardev
socket,id=monitor,server,nowait,path=/var/cache/obs/worker/root_1/root.qemu
/monitor -mon chardev=monitor,mode=readline -smp 8 [ 10s]
c[?7l[2J[0mSeaBIOS (version rel-1.12.0-0-ga698c89-rebuilt.opensuse.org) [
13s] Booting from ROM..c[?7l[2J[ 2.518420] dracut-pre-udev[231]:
modprobe: FATAL: Module kqemu not found in directory
/lib/modules/4.12.14-lp150.11-default [ 13s] [ 2.635247]
dracut-pre-udev[231]: modprobe: FATAL: Module ext2 not found in directory
/lib/modules/4.12.14-lp150.11-default [ 13s] [ 2.667787]
dracut-pre-udev[231]: modprobe: FATAL: Module ext3 not found in directory
/lib/modules/4.12.14-lp150.11-default [ 14s] [ 3.712514]
dracut-pre-udev[231]: modprobe: FATAL: Module ibmvscsi not found in
directory /lib/modules/4.12.14-lp150.11-default [ 14s] [ 3.773479]
dracut-pre-udev[231]: modprobe: FATAL: Module ibmveth not found in
directory /lib/modules/4.12.14-lp150.11-default [ 16s] /bin/bash: error
while loading shared libraries: libreadline.so.8: cannot open shared object
file: No such file or directory [ 16s] [ 5.267243] Kernel panic - not
syncing: Attempted to kill init! exitcode=0x00007f00 [ 16s] [
5.267243]
[ 16s] [ 5.268429] CPU: 0 PID: 1 Comm: build Not tainted
4.12.14-lp150.11-default #1 openSUSE Leap 15.0 (unreleased) [ 16s] [
5.268429] Hardware name: QEMU Standard PC (i440FX + PIIX, 1996), BIOS
rel-1.12.0-0-ga698c89-rebuilt.opensuse.org 04/01/2014 [ 16s] [
5.268429] Call Trace:
[ 16s] [ 5.268429] dump_stack+0x5c/0x82
[ 16s] [ 5.268429] panic+0xd5/0x230
[ 16s] [ 5.268429] do_exit+0xb2e/0xb30
[ 16s] [ 5.268429] ? __schedule+0x247/0x870
[ 16s] [ 5.268429] do_group_exit+0x3a/0xa0
[ 16s] [ 5.268429] SyS_exit_group+0x10/0x10
[ 16s] [ 5.268429] do_syscall_64+0x7b/0x140
[ 16s] [ 5.268429] entry_SYSCALL_64_after_hwframe+0x3d/0xa2
[ 16s] [ 5.268429] RIP: 0033:0x7f6164b6e288
[ 16s] [ 5.268429] RSP: 002b:00007ffc94f644c8 EFLAGS: 00000202
ORIG_RAX: 00000000000000e7 [ 16s] [ 5.302348] RAX: ffffffffffffffda
RBX: 00007ffc94f64920 RCX: 00007f6164b6e288 [ 16s] [ 5.302348] RDX:
000000000000007f RSI: 000000000000003c RDI: 000000000000007f [ 16s] [
5.302348] RBP: 0000000000000000 R08: 00000000000000e7 R09: ffffffffffffffff
[ 16s] [ 5.325271] R10: 0000000000000000 R11: 0000000000000202 R12:
00007ffc94f64940 [ 16s] [ 5.325271] R13: 00007f6164b74c28 R14:
0000000000000002 R15: 00007f6164b729fc [ 16s] [ 5.325271] Kernel
Offset: disabled
[ 16s] [ 5.325271] Rebooting in 1 seconds..
[ 17s] ### VM INTERACTION END ###
[ 17s] No buildstatus set, either the base system is broken
(kernel/initrd/udev/glibc/bash/perl) [ 17s] or the build host has a
kernel or hardware problem...

For complete logs check:
https://build.opensuse.org/package/live_build_log/home:czanik:branches:Base:
System/syslog-ng/openSUSE_Leap_15.0/x86_64


Bye,

CzP


--

Adrian Schroeter <adrian@xxxxxxx>
Build Infrastructure Project Manager

SUSE Software Solutions Germany GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
(HRB 247165, AG München), Geschäftsführer: Felix Imendörffer




--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References