Mailinglist Archive: opensuse-buildservice (39 mails)

< Previous Next >
Re: [opensuse-buildservice] multibuild: no binaries
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Tue, 11 Jun 2019 18:30:31 +0200
  • Message-id: <2327380.akzOl2sZ5m@linux-ywca>
On Dienstag, 11. Juni 2019, 17:42:27 CEST Morschhäuser, Mark wrote:
Hi,

I have some multibuild packages that properly create rpm files, but OBS
tells me "no binaries" if I want to see what it created. If I go to the
download repository the files are there. Is this normal in OBS 2.9? I saw
that the build.opensuse.org instance shows the binaries.

where does it tell you "no binaries" ? My guess is that you look in the
wrong build package ?

Also: could this be the problem for the following issue I have?
I have a multibuild postgresql package that creates a basically identical
package for Postgres 9.5 and 9.4. Both packages really exist and they each
provide "postgresql-noarch" for their version (checked with rpm -qp
--provides). But one package in the same project does not find the 9.5
version: "nothing provides postgresql-noarch >= 9.5 needed by
postgresql95-devel". How can I fix this visibility issue?

This is not solvable in the same repository. You can only build against a
package of one version by a given name.

=> create another repo to build the other version.

(Please note that is independent of the publishing. You can have multiple
versions published)

--

Adrian Schroeter
SUSE Linux Products GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
email: adrian@xxxxxxx




--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >