Mailinglist Archive: opensuse-buildservice (41 mails)

< Previous Next >
[opensuse-buildservice] osc and gnome keyring
Hi

Can anyone offer any advice on how to get this to work. In the past it worked
for me but lately I've been unable to get it to work and I've had to resort to,
ahem, clear text passwords.

https://en.opensuse.org/openSUSE:OSC "There have been reports that with ... add
solely the line gnome_keyring=1 instead of keyring=1 to the server section."

Is "instead of keyring=1" correct or does it mean instead of "use_keyring=1"?
Anyways, I've tried every version of use_keyring=1, keyring=1, gnome_keyring=1,
removing python2-keyring and all I get is "Server returned an error: HTTP
Error 401: Unauthorized"

This is using a basic 'osc list' query

I have an entry in my gnome keyring for <my external userid>@api.opensuse.org.
It's unfortunate that the debug/verbose options don't provide any info about
the interaction with the keyring as if I remove the opensuse entry from the
keyring I get the exact same error so it's hard to tell what is occurring.

Thanks

$ rpm -q openSUSE-release
openSUSE-release-20190320-77.1.x86_64

$ osc --version
0.164.2

$ osc -d -v -A https://api.opensuse.org list
makeurl: https://api.opensuse.org ['source'] {}
GET https://api.opensuse.org/source
Server returned an error: HTTP Error 401: Unauthorized
Date: Fri, 22 Mar 2019 19:24:40 GMT
Server: Apache/2.4.23 (Linux/SUSE)
WWW-Authenticate: Basic realm="Use your novell account"
Vary: accept-language,accept-charset
Strict-Transport-Security: max-age=31536000
Upgrade: h2
Connection: Upgrade, close
Accept-Ranges: bytes
Transfer-Encoding: chunked
Content-Type: text/html; charset=utf-8
Content-Language: en

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd";>
<html xmlns="http://www.w3.org/1999/xhtml"; lang="en" xml:lang="en">
<head>
<title>Authentication required!</title>
<link rev="made" href="mailto:%5bno%20address%20given%5d"; />
<style type="text/css"><!--/*--><![CDATA[/*><!--*/
body { color: #000000; background-color: #FFFFFF; }
a:link { color: #0000CC; }
p, address {margin-left: 3em;}
span {font-size: smaller;}
/*]]>*/--></style>
</head>

<body>
<h1>Authentication required!</h1>
<p>


This server could not verify that you are authorized to access
the URL "/source".
You either supplied the wrong credentials (e.g., bad password), or your
browser doesn't understand how to supply the credentials required.

</p>
<p>


In case you are allowed to request the document, please
check your user-id and password and try again.

</p>
<p>
If you think this is a server error, please contact
the <a href="mailto:%5bno%20address%20given%5d";>webmaster</a>.

</p>

<h2>Error 401</h2>
<address>
<a href="/">api.opensuse.org</a><br />
<span>Apache/2.4.23 (Linux/SUSE)</span>
</address>
</bod
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups