Mailinglist Archive: opensuse-buildservice (65 mails)

< Previous Next >
[opensuse-buildservice] Strange Build failures on Buildservice
Hi guys,

Michael and I are trying to update the espresso package in OpenSuse:
https://build.opensuse.org/package/show/home:cjunghans:branches:devel:languages:python/python-espressomd

We tracked all issues here: https://github.com/espressomd/espresso/issues/2258

But now we are left with 2 issues, which hard to solve outside of the
Build service VMs:
1.) Segfault on openSUSE_Factory_ARM armv7l
Details:
https://github.com/espressomd/espresso/issues/2258#issuecomment-420988560
Michael's attempt so far:
https://github.com/espressomd/espresso/issues/2258#issuecomment-421710470
Cannot be reproduced!

2.) Build on openSUSE_Tumbleweed i586 is super slow and runs out of time.

Additionally there are 2 minor infrastructure issues:
1.) On openSUSE_Tumbleweed x86_64, -grecord-gcc-switches is missing so
we get hundreds of warnings like:
W: python-espressomd no-rpm-opt-flags
All non-Tumbleweed builds don't have that warning
2.) On SLE_12_SP4 x86_64, we cannot install the openmpi-devel package
anymore, error:
File /usr/lib64/mpi/gcc/openmpi/lib64/mpi.mod conflicts between
attempted installs of openmpi-devel-1.10.7-1.15.x86_64 and
openmpi-compat-1.8.1-3.1.x86_64

Any help on the first two issues would be appreciated.

Cheers,

Christoph

--
Christoph Junghans
Web: http://www.compphys.de
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups