Mailinglist Archive: opensuse-buildservice (88 mails)

< Previous Next >
[opensuse-buildservice] Error with composer and Fedora 28 on OBS 2.9
  • From: Neal Gompa <ngompa13@xxxxxxxxx>
  • Date: Sat, 9 Jun 2018 09:42:43 -0400
  • Message-id: <CAEg-Je-mrR8JVW_Y7_Vh=zoNZ60AC1R2S-KORj1kY0sYZOo7ng@mail.gmail.com>
Hey,

One of the packages I'm building attempts to retrieve composer in
Fedora 28 on my self-hosted OBS (v2.9.3), but I get the following
error:

cannot parse dependency (php-composer(composer/ca-bundle) >= 1.0 with
php-composer(composer/ca-bundle) < 2) from composer, cannot parse
dependency (php-composer(composer/semver) >= 1.0 with
php-composer(composer/semver) < 2) from composer, cannot parse
dependency (php-composer(composer/spdx-licenses) >= 1.2 with
php-composer(composer/spdx-licenses) < 2) from composer, cannot parse
dependency (php-composer(psr/log) >= 1.0 with php-composer(psr/log) <
2) from composer, cannot parse dependency
(php-composer(seld/cli-prompt) >= 1.0 with
php-composer(seld/cli-prompt) < 2) from composer, cannot parse
dependency (php-composer(seld/jsonlint) >= 1.4 with
php-composer(seld/jsonlint) < 2) from composer, cannot parse
dependency (php-composer(seld/phar-utils) >= 1.0 with
php-composer(seld/phar-utils) < 2) from composer

I thought perl-BSSolv was up to date enough to handle these kinds of
dependencies in OBS 2.9?

--
真実はいつも一つ!/ Always, there's only one truth!
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages