Mailinglist Archive: opensuse-buildservice (88 mails)

< Previous Next >
Re: [opensuse-buildservice] Building OBS 2.9 in own OBS issues


On 06/01/2018 10:13 AM, Karsten Keil wrote:
Hi,

yesterday I tried to import and build the OBS:Server:2.9 project in my
private OBS 2.8 instance and found some issues. Import was done with osc
copypac, build was tried for SLE12 SP3.

1.) package build failed to extract some spec/changes files
(build-mkbaselibs-sle stuff), seems that was removed some time after the
_service was written and last service run. Solution for me, I added
<param name="version">20180111</param>
<param name="revision">4db855ee8d1b81ac46c4b54a41724de587782bb4</param>
to the _service to get the same version as used in the official build.

2.) Lot of ruby gems did stay unresolved because of ruby > 2.2.2 build
requirements. Hmm, looked at the project config, but it was empty and
indeed SLE12 SP3 prefers ruby2.1. Seems somebody did delete the project
config after building the stable release (Is this normal ?). Solution
for me: using the project config from the OBS:Server:2.9:Staging project.
After this everything did build.


The OBS:Server:2.9 project is just the release target of OBS:Server:2.9:Staging. Once we tested a new release in *:Staging we release the binaries to OBS:Server:2.9.
Hence we don't need the project config there.

Another issue was building openSUSE:Tools, the service file of
obs-service-generator_pom points to a dead link, so it stays broken,
maybe somebody can fix it, I did download the the service result and
removed the _service file.

Thanks
Karsten

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups
References