Mailinglist Archive: opensuse-buildservice (43 mails)

< Previous Next >
Re: [opensuse-buildservice] Issue installing Okular via Zypper
On Donnerstag, 5. April 2018, 10:30:45 CEST wrote Edward Maurer:
Hello,

just before stating my problem, feel free to send me to another
mailing list or KDE Okluar Team directly if this is not appropriate
here. Hope you have an spontaneous idea to help me out.

My institute system is:

openSUSE Leap 42.3 64-bit
GNOME 3.20.2

We were trying to install Okular via
https://software.opensuse.org/download.html?project=KDE%3AApplications&package=okular

What happened?:
Problem: nothing provides libQt5Core.so.5(Qt_5.10)(64bit) needed by
okular-17.12.3-2.2.x86_64

You need to have Qt 5.10 installed. software.o.o is pointing yast to add
also the repo from KDE:Qt5 project.

I suppose this is not enabled on your system?

We proceed and tried to solve by:
Please see terminal input below

What B. Geuken recommended was to install libQt5Core-devel as this
provides /usr/lib64/libQt5Core.so - otherwise it would be a bug and we

you need that only for compiling stuff

shall go over to the KDE:Applications project. But unfortunately this
didn't work out as it is already installed (libQt5Core.so). Probably
Okular just cannot find it and it is finally an Okular-issue.

Do you see anything else to solve this issue expect put my claim to
Okular devs?

Kind regards,
Ed

----------------
Terminal input
----------------

sudo zypper addrepo
https://download.opensuse.org/repositories/KDE:Applications/KDE_Frameworks5_openSUSE_Leap_42.3/KDE:Applicatio
ns.repo
Adding repository 'KDE:Applications
(KDE_Frameworks5_openSUSE_Leap_42.3)' [done]
Repository named 'KDE_Applications' already exists. Please use another alias.
Repository priorities in effect: (See 'zypper lr -P'
for details)
96 (raised priority) : 2 repositories
99 (default priority) : 6 repositories
sudo zypper refresh
Retrieving repository 'KDE:Applications
(KDE_Frameworks5_openSUSE_Leap_42.[done]
Building repository 'KDE:Applications
(KDE_Frameworks5_openSUSE_Leap_42.3)[done]
Repository 'NVIDIA' is up to date.
Retrieving repository 'Software for Scientists and Engineers
(openSUSE_Lea[done]
Building repository 'Software for Scientists and Engineers
(openSUSE_Leap_[done]
Repository 'Virtualization (openSUSE_Leap_42.3)' is up to date.
Repository 'openSUSE-Leap-42.3-Non-Oss' is up to date.
Repository 'openSUSE-Leap-42.3-Oss' is up to date.
Repository 'openSUSE-Leap-42.3-Update' is up to date.
Repository 'openSUSE-Leap-42.3-Update-Non-Oss' is up to date.
All repositories have been refreshed.
sudo zypper install okular
Loading repository data...
Reading installed packages...
Resolving package dependencies...
Problem: nothing provides libQt5Core.so.5(Qt_5.10)(64bit) needed by
okular-17.12.3-2.2.x86_64
Solution 1: do not install okular-17.12.3-2.2.x86_64
Solution 2: break okular-17.12.3-2.2.x86_64 by ignoring some of
its dependencies
Choose from above solutions by number or cancel [1/2/c] (c): 1
Resolving dependencies...
Resolving package dependencies...
Nothing to do.
sudo zypper se *libqt*
sudo zypper in locate
Loading repository data...
Reading installed packages...
'locate' not found in package names. Trying capabilities.
No provider of 'locate' found.
Resolving package dependencies...
Nothing to do.
sudo zypper addrepo
https://download.opensuse.org/repositories/server:search/openSUSE_Leap_42.3/server:search.repo
Adding repository 'Websearch engines and tools
(openSUSE_Leap_42.3)' .....[done]
Repository 'Websearch engines and tools (openSUSE_Leap_42.3)'
successfully added
URI :
http://download.opensuse.org/repositories/server:/search/openSUSE_Leap_42.3/
Enabled : Yes
GPG Check : Yes
Autorefresh : No
Priority : 99 (default priority)
Repository priorities in effect: (See 'zypper lr
-P' for details)
96 (raised priority) : 2 repositories
99 (default priority) : 7 repositories
sudo zypper refresh
Repository 'KDE:Applications
(KDE_Frameworks5_openSUSE_Leap_42.3)' is up to date
Repository 'NVIDIA' is up to date.
Repository 'Software for Scientists and Engineers
(openSUSE_Leap_42.3)' is up to
Repository 'Virtualization (openSUSE_Leap_42.3)' is up to date.
Repository 'openSUSE-Leap-42.3-Non-Oss' is up to date.
Repository 'openSUSE-Leap-42.3-Oss' is up to date.
Repository 'openSUSE-Leap-42.3-Update' is up to date.
Repository 'openSUSE-Leap-42.3-Update-Non-Oss' is up to date.
Retrieving repository 'Websearch engines and tools
(openSUSE_Leap_42.3)' meta[\]
New repository or package signing key received:
Repository: Websearch engines and tools (openSUSE_Leap_42.3)
Key Name: server:search OBS Project
<server:search@xxxxxxxxxxxxxxxxxx>
Key Fingerprint: ---
Key Created: ---
Key Expires: ---
Rpm Name: ---
(Content deleted by me)
Do you want to reject the key, trust temporarily, or trust always?
[r/t/a/? shows all options] (r): a
Retrieving repository 'Websearch engines and tools
(openSUSE_Leap_42.3)' m[done]
Building repository 'Websearch engines and tools
(openSUSE_Leap_42.3)' cac[done]
All repositories have been refreshed.
sudo zypper install mlocate
Loading repository data...
Reading installed packages...
Resolving package dependencies...
The following 2 NEW packages are going to be installed:
mlocate mlocate-lang
The following recommended package was automatically selected:
mlocate-lang
sudo updatedb
locate libQt5Core.so
/..../11.06.010-R8/STAR-View+11.06.010/bin/libQt5Core.so.5
/usr/lib64/libQt5Core.so.5
/usr/lib64/libQt5Core.so.5.6
/usr/lib64/libQt5Core.so.5.6.2
sudo zypper install okular
Loading repository data...
Reading installed packages...
Resolving package dependencies...
Problem: nothing provides libQt5Core.so.5(Qt_5.10)(64bit) needed
by okular-17.12.3-2.2.x86_64
Solution 1: do not install okular-17.12.3-2.2.x86_64
Solution 2: break okular-17.12.3-2.2.x86_64 by ignoring some of
its dependencies
Choose from above solutions by number or cancel [1/2/c] (c): 2
Resolving dependencies...
Resolving package dependencies...
The following 125 NEW packages are going to be installed:
drkonqi5 kaccounts-integration kaccounts-integration-lang kaccounts-providers
kaccounts-providers-lang kconf_update5 kcoreaddons kcoreaddons-lang
kdbusaddons-tools kded kded-lang kdoctools kdoctools-lang kglobalaccel5
kimageformats kinit kinit-lang kio kio-core kio-extras5 kio-extras5-lang
kio-lang kpackage kpackage-lang kservice kservice-lang ktp-accounts-kcm
ktp-accounts-kcm-lang libaccounts-glib0 libaccounts-qt5-1 libchm0
libdbusmenu-qt5-2 libdjvulibre21 libepub0 libkaccounts1 libKF5Activities5
libKF5Archive5 libKF5Attica5 libKF5Auth5 libKF5Auth5-lang libKF5Bookmarks5
libKF5Bookmarks5-lang libKF5Codecs5 libKF5Codecs5-lang libKF5Completion5
libKF5Completion5-lang libKF5ConfgCore5 libKF5ConfgCore5-lang
libKF5ConfgGui5 libKF5ConfgWidgets5 libKF5ConfgWidgets5-lang
libKF5CoreAddons5 libKF5Crash5 libKF5DBusAddons5 libKF5DBusAddons5-lang
libKF5Declarative5 libKF5Declarative5-lang libKF5DNSSD5 libKF5DNSSD5-lang
libKF5DocTools5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5 libKF5GuiAddons5 libKF5I18n5 libKF5I18n5-lang
libKF5IconThemes5 libKF5IconThemes5-lang libKF5IdleTime5 libKF5ItemViews5
libKF5ItemViews5-lang libKF5JobWidgets5 libKF5JobWidgets5-lang libKF5JS5
libKF5JSApi5 libKF5KDELibs4Support5 libKF5KExiv2-15_0_0 libKF5KHtml5
libKF5KHtml5-lang libKF5Notifcations5 libKF5Notifcations5-lang libKF5Parts5
libKF5Parts5-lang libKF5Pty5 libKF5Pty5-lang libKF5Solid5 libKF5Solid5-lang
libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5 libKF5TextWidgets5
libKF5TextWidgets5-lang libKF5ThreadWeaver5 libKF5Wallet5
libKF5WidgetsAddons5
libKF5WidgetsAddons5-lang libKF5WindowSystem5 libKF5WindowSystem5-lang
libKF5XmlGui5 libKF5XmlGui5-lang libKF5XmlRpcClient5
libKF5XmlRpcClient5-lang
libktpaccountskcminternal9 libmarkdown2 libphonon4qt5 libpolkit-qt5-1-1
libqca-qt5 libqca-qt5-plugins libQt5Script5 libsignon-qt5-1
libtelepathy-qt5-0
media-player-info mobipocket okular okular-lang
phonon4qt5-backend-gstreamer
purpose purpose-lang signond signond-libs signon-plugin-oauth2
signon-plugins
signon-ui solid-imports solid-tools
The following 55 recommended packages were automatically selected:
drkonqi5 kaccounts-integration kaccounts-integration-lang
kaccounts-providers
kaccounts-providers-lang kconf_update5 kcoreaddons kcoreaddons-lang
kdbusaddons-tools kded kded-lang kdoctools kdoctools-lang kglobalaccel5
kimageformats kinit kinit-lang kio-extras5 kio-extras5-lang kio-lang
kpackage-lang kservice-lang ktp-accounts-kcm-lang libKF5Auth5-lang
libKF5Bookmarks5-lang libKF5Codecs5-lang libKF5Completion5-lang
libKF5ConfgCore5-lang libKF5ConfgWidgets5-lang libKF5DBusAddons5-lang
libKF5Declarative5-lang libKF5DNSSD5-lang libKF5GlobalAccel5-lang
libKF5I18n5-lang libKF5IconThemes5-lang libKF5ItemViews5-lang
libKF5JobWidgets5-lang libKF5KHtml5-lang libKF5Notifcations5-lang
libKF5Parts5-lang libKF5Pty5-lang libKF5Solid5-lang libKF5SonnetCore5-lang
libKF5TextWidgets5-lang libKF5WidgetsAddons5-lang libKF5WindowSystem5-lang
libKF5XmlGui5-lang libKF5XmlRpcClient5-lang libqca-qt5-plugins
media-player-info okular-lang phonon4qt5-backend-gstreamer purpose-lang
solid-imports solid-tools
okular
okular: /usr/lib64/libQt5Core.so.5: version `Qt_5.10' not found
(required by okular)




--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg
Germany




--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References