Mailinglist Archive: opensuse-buildservice (89 mails)

< Previous Next >
Re: [opensuse-buildservice] Build result state not updating

On 1/24/18 3:59 PM, Florian Riedl wrote:
Hi everybody.

The rsyslog project is currently trying out OBS to transition to this
build environment in the future. So far, getting into the system is
working well.

But, since yesterday I am observing a strange behaviour with the
builds. When I did my first steps last week, the schedulers were
usually quick to update the state of a build. But yesterday, this
seems to not work correctly anymore. What I observed was that
yesterday the scheduler would only initiate the build for the ppc64
architecture, but not for i586 or x86_64 builds. I wasn't thinking
much of it.

But today the i586 builds seem to be "succeeded" according to the
status and x64 builds are finished, but not yet succeeded.

The question is now: Is this a known problem? Is the scheduler just
"hanging"? Can I do something about this?

Interesting note: While writing this, I decided to trigger one rebuild
and suddenly all the states switched to "succeeded". So, it looks like
something was actually locked up somehow. Still, the questions stay
the same. Any insight you guys can provide is much appreciated.

Regards,
Florian


Hi Florian,

the schedulers for x86_64 and i586 are working fine: For example, yesterday around 20:00 there were around 20 project updates to schedule for ppc64, 15.000+ for i586 and 30.000+ for x86_64. With this you can already guess the outcome: All schedulers are working, yet some have more work to do and so your project has to wait long for it to get updated and rescheduled, see https://build.opensuse.org/monitor

Greetings,

Tobias

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References