Mailinglist Archive: opensuse-buildservice (99 mails)

< Previous Next >
[opensuse-buildservice] Seemingly inconsistent API results for Factory/standard repo
  • From: Jimmy Berry <jberry@xxxxxxxx>
  • Date: Wed, 16 Aug 2017 08:41:21 -0500
  • Message-id: <42942499.CZc6GR6dDi@boomba.local>
Part of the repo-checker bot is crashing when trying to reverse lookup the
package to which rpms producing installcheck/file conflict errors belong. The
rpm causing the issue is not supposed to exist so the error makes sense.
Unfortunately, the /public API is still returning it even after the package
was disabled and binaries wiped.

RPM causing the error:

liblua5_3-32bit-5.3.3-2.2.x86_64

osc api '/public/build/openSUSE:Factory/standard/x86_64/_repository?
view=binaryversions&nometa=1'

<binary name="liblua5_3-32bit.rpm" sizek="118"
hdrmd5="3970ae129623ebcd89b9cbb0256f13f6" />
<binary name="liblua5_3-5-32bit.rpm" sizek="119"
hdrmd5="ab89d49de452657f6f6575b83d4ddcd3" />

The first of the two should not exist. Only the rpm with 5_3-5 in the name
should exist.

liblua5_3-32bit
liblua5_3-5-32bit

The displays on OBS indicate no binaries for the lua package which produces
the 5_3 rpm which is desired.

https://build.opensuse.org/package/binaries/openSUSE:Factory/lua?
repository=standard
https://build.opensuse.org/package/binaries/openSUSE:Factory/lua53?
repository=standard

It looks like the rpms are not properly being wiped from the repository.

--
Jimmy
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups