Mailinglist Archive: opensuse-buildservice (81 mails)

< Previous Next >
Re: [opensuse-buildservice] Leap: provider krb5 is conflicted by installed krb5-mini
On Mon, Feb 13, Olaf Hering wrote:

Since end of last week one pkg in external buildservice is in state
unresolvable for Leap 42.1 and 42.2:

unresolvable: conflict for provider of krb5 needed by samba-libs
(provider krb5 is conflicted by installed krb5-mini)

The same bug is in 42.3.
Is this the correct way to fix a non-OBS project?

# for freetuxtv. For some reason libcurl+libvlc+samba-libs prefers krb5-mini
instead of krb5 in Leap
%if 0%{?suse_version} == 1315
%if 0%{?is_opensuse}
#
%if 0%{?sle_version} == 120200
# Leap 42.2
Conflict: libcurl4:krb5-mini
Prefer: libcurl4:krb5
%endif
#
%if 0%{?sle_version} == 120100
# Leap 42.1
Conflict: libcurl4:krb5-mini
Prefer: libcurl4:krb5
%define _without_xmms2 1
Macros:
%_without_xmms2 1
:Macros
%endif
#
%endif
%endif


Olaf
< Previous Next >
List Navigation
This Thread
  • No further messages