Mailinglist Archive: opensuse-buildservice (176 mails)

< Previous Next >
[opensuse-buildservice] Not able to differentiate between openSUSE Leap and SLES (12)
It's currently not possible to differentiate between Leap 42.1 and SLES 12.
openSUSE Leap 42.3 %if 0%{?leap_version} == 420300 could also be '%if 0%{?sle_version} == 120300' (SLE12 SP3)
openSUSE Leap 42.2 %if 0%{?leap_version} == 420200 could also be '%if 0%{?sle_version} == 120200' (SLE12 SP2)
openSUSE Leap 42.1 %if 0%{?sle_version} == 120100 (SLE12 SP1), 420100 is not defined :(
openSUSE Leap 42.x %if 0%{?suse_version} == 1315 could also be SLE12*; to distinguish between 42.1 (SLE12 SP1) and 42.2 (SLE12 SP2) one has to consult the sle_version (120100 for 42.1/SLE12 SP1, 120200 for 42.2/SLE12 SP2)

https://en.opensuse.org/openSUSE:Build_Service_cross_distribution_howto

It's useful If I would be able to differentiate between both distro versions:
Like in this case:
https://build.opensuse.org/package/show/server:php:applications/drupal8

Nginx is not provided for SLES12SP2.

Regards,

Joop.
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups