Mailinglist Archive: opensuse-buildservice (90 mails)

< Previous Next >
Re: [opensuse-buildservice] Leap: provider krb5 is conflicted by installed krb5-mini
Am Mon, 13 Feb 2017 16:56:55 +0100
schrieb Olaf Hering <olaf@xxxxxxxxx>:

Since end of last week one pkg in external buildservice is in state
unresolvable for Leap 42.1 and 42.2:

unresolvable: conflict for provider of krb5 needed by samba-libs
(provider krb5 is conflicted by installed krb5-mini)

Why does that happen only for one pkg in the same project, but not for
others?

This one works:
BuildRequires: fdupes
BuildRequires: gcc-c++
BuildRequires: gnome-common
BuildRequires: gstreamer-0_10-devel
BuildRequires: gstreamer-0_10-plugins-base-devel
BuildRequires: intltool
BuildRequires: update-desktop-files
BuildRequires: pkgconfig(dbus-glib-1)
BuildRequires: pkgconfig(gconfmm-2.6)
BuildRequires: pkgconfig(giomm-2.4)
BuildRequires: pkgconfig(gthread-2.0)
BuildRequires: pkgconfig(gtkmm-2.4)
BuildRequires: pkgconfig(libvlc)
BuildRequires: pkgconfig(libxml++-2.6)
BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(unique-1.0)


This one does not work:
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: gettext-tools
BuildRequires: intltool
BuildRequires: libtool
BuildRequires: pkg-config
BuildRequires: pkgconfig(dbus-glib-1) >= 0.74
BuildRequires: pkgconfig(gio-2.0) >= 2.26.0
BuildRequires: pkgconfig(glib-2.0) >= 2.26.0
BuildRequires: pkgconfig(gobject-2.0) >= 2.26.0
BuildRequires: pkgconfig(gtk+-3.0)
BuildRequires: pkgconfig(libcurl) >= 7.18
BuildRequires: pkgconfig(libnotify) >= 0.4
BuildRequires: pkgconfig(libvlc)
BuildRequires: pkgconfig(sqlite3) >= 3.4

Removing libvlc, which links to samba, fixes the unsolvable.
Any idea how to debug it?

Olaf
< Previous Next >
References