Mailinglist Archive: opensuse-buildservice (90 mails)

< Previous Next >
Re: [opensuse-buildservice] What to do about "broken" state
On Tue, Feb 14, 2017, at 09:19, Greg Ward wrote:
Yeah, I figured out the mouse-over already. I get the same message at
the command line:

obs-new:/tmp/home:gward/sortu # osc results -v
sl67 x86_64 broken: bad build configuration, no
build type defined or detected
sl67 i586 broken: bad build configuration, no
build type defined or detected
ol7 x86_64 succeeded
c7 x86_64 succeeded

But I don't *understand* the error.

Hmmm: I just realized I didn't do anything to define a build worker for
SL 6.7. My colleague, who created this private instance, took care of
the ol7 (Oracle Linux 7) build worker When I added c7 (CentOS 7), it
just worked without me adding a builder, and I don't understand why. Now
I've added sl67 (Scientific Linux 6.7) without adding a build worker,
and it doesn't work.

Maybe my question should be: why are my CentOS 7 builds working even
though I did not define a build worker?

The plot thickens. My formerly broken packages now build. I have no idea
why. Here's what I did:

* let time elapse: ~36 h while I dug into OBS source code, slept, worked
on other things, etc.
* made bogus whitespace-only commits to the .spec files to force a build

It appears that elapsed time fixed my problem, i.e. now I have build
workers capable of building for Scientific Linux 6.7. This is exactly
what I observed when I added CentOS 7, only the time elapsed was longer.
I still don't understand what happened.

Related question: how do you trigger a build without a bogus
whitespace-only commit?

Thanks!

Greg
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups