Mailinglist Archive: opensuse-buildservice (177 mails)

< Previous Next >
Re: [opensuse-buildservice] gpg: [don't know]: 1st length byte missing
Hi Helgi,

Am 19.12.2016 um 15:49 schrieb Helgi Waag:
I am having trouble when signing my packages

# sign

gpg: [don't know]: 1st length byte missing
gpg: keydb_search failed: Invalid packet
gpg: skipped "xxxx@localhost": Invalid packet
gpg: signing failed: Invalid packet

I've tried regenerating gpg key with the same result.

Looks like your gpg pubring or secring is corrupt. That's not really
an OBS issue, you should get the same error if you run gpg

The error only seems to happen if signd is started via init, and goes away if
I start signd manually:

I had some similar issue some time ago. I do not remember all details,
but in the end some environment variable was not set in the init case,
so it did search the gpg keyring under / instead of the correct place.



Linux Consultant, Linux Kernel Developer
Tel.: +49-175-7249132
Mail: keil@xxxxxxxxxxxxx

B1 Systems GmbH
Osterfeldstra├če 7 / 85088 Vohburg /
GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >