Mailinglist Archive: opensuse-buildservice (177 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: A non operating suse_version macro?
  • From: Hans-Peter Jansen <hpj@xxxxxxxxx>
  • Date: Thu, 08 Dec 2016 21:07:53 +0100
  • Message-id: <2989403.HzuIXiDgkE@xrated>
On Dienstag, 6. Dezember 2016 17:03:36 Hans-Peter Jansen wrote:
On Dienstag, 6. Dezember 2016 11:13:35 Andreas Schwab wrote:
On Dez 06 2016, Hans-Peter Jansen <hpj@xxxxxxxxx> wrote:
Giving kvm enough memory is not enough to build Qt 5.7.1, because it
out of filesystem space. I tried to adopt some hints, e.g.:

dd if=/dev/zero of=/var/tmp/build-root/img bs=1M count=16384
mkfs.ext3 /var/tmp/build-root/img

but this preparation is reverted by build:

Running build
VM_IMAGE: /var/tmp/build-root/img, VM_SWAP: /var/tmp/build-root/swap
Resizing /var/tmp/build-root/img (4096M)

Adjust build-vmdisk-rootsize in .oscrc.

Okay, thanks. Now it successfully builds the libqt5-qtbase package with kvm.

Hence this issue boils down to: builds perfectly on local facilities, but
fails consistently on BS just for 13.2 due to not performing the exclude


Any ideas, anybody?

This issue is still pending. I know, everybody is busy, and nobody cares about
fossils like 13.2, but doesn't this point to some BS spec evaluator issues?!?

Meanwhile, I tried this approach:

%if 0%{?suse_version} == 1315 || 0%{?suse_version} > 1320

but again, BS tries to package for 13.2:


No fun,

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >