Mailinglist Archive: opensuse-buildservice (177 mails)

< Previous Next >
[opensuse-buildservice] osc/obs SSL timeouts
Hello list,

since a few weeks I have many problems with SSL timeouts when connecting
to the OBS with osc.
It happens in different stages with every osc command that connects to
the Build Service (co, up, build, etc.). Sometimes it works flawless,
but often I have to interrupt it and retry it. It fails multiple times
until it works. It makes no difference if it is a POST or a GET request
and the stage in that it times out changes from try to try. A current
example;

user@host:~/repos> osc -v -d build openSUSE_Tumbleweed --no-verify --clean
makeurl: https://api.opensuse.org ['source', 'home:buschmann23:weblate',
'_meta'] []
GET https://api.opensuse.org/source/home:buschmann23:weblate/_meta
makeurl: https://api.opensuse.org ['source', 'home:buschmann23:weblate',
'weblate'] cmd=getprojectservices
POST
https://api.opensuse.org/source/home:buschmann23:weblate/weblate?cmd=getprojectservices
Building weblate.spec for openSUSE_Tumbleweed/x86_64
Getting buildinfo from server and store to
/home/buschmann/Dokumente/Entwicklung/Build
Service/home:buschmann23:weblate/weblate/.osc/_buildinfo-openSUSE_Tumbleweed-x86_64.xml
makeurl: https://api.opensuse.org ['build', 'home:buschmann23:weblate',
'openSUSE_Tumbleweed', 'x86_64', 'weblate', '_buildinfo'] []
POST
https://api.opensuse.org/build/home:buschmann23:weblate/openSUSE_Tumbleweed/x86_64/weblate/_buildinfo


Any idea how I can try to investigate this issue? Can the problem be
related to my ISP that uses IPv6 with DS-Lite? I never have this
problems when using the same setup on another location with pure IPv4
addresses.


Best greetings

Matthias Fehring

--
Das Gesetz hat zum Schneckengang verdorben, was Adlerflug geworden wäre.
(Friedrich Schiller - Die Räuber)

www.buschmann23.de
GPG-Key: 3A70A936614C3258
GPG Fingerprint: D786 DDF8 4CA9 00BC CDE0 9A5F CCC5 125D 6E87 D4FC


< Previous Next >
This Thread