Mailinglist Archive: opensuse-buildservice (124 mails)

< Previous Next >
Re: [opensuse-buildservice] Corrupt diffcache?
  • From: Marcus Hüwe <suse-tux@xxxxxx>
  • Date: Thu, 4 Aug 2016 14:12:31 +0200
  • Message-id: <20160804121231.zsg3je3j6l3rfawl@linux>
On 2016-08-02 23:46:39 +0200, Andreas Schwab wrote:
When I run "osc rdiff -c 442 Base:System glibc" I get no output, but I'd
expect to get the same diff that I get from "osc rq show -d 407107".

Seeing no outpout when running "osc rdiff -c 442..." is "expected", because
the link target/rev in 441 is not fixed. Hence, 441 is expanded against
openSUSE:Factory glibc HEAD, which already contains the changes from 442.
In order to get the expected diff, you need to to fix the link target/rev
via the olinkrev parameter. For instance,

curl -X POST -d '' \

'https://api.opensuse.org/source/Base:System/glibc?cmd=diff&orev=441&olinkrev=204&rev=442&filelimit=0&expand=1'

yields the same result as "osc rq show -d 407107".

Earlier revisions don't have this problem. Also, when issuing the api
call with "expand=0" I get a correct diff. The corresponding expanded
revisions are c60457ca347e1be482c43fab57813ee3 and
139d86ab44417129f81bbc53807137d0 and are clearly different.

Hmm how did you calculate these expanded revs?


Marcus
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References