Mailinglist Archive: opensuse-buildservice (117 mails)

< Previous Next >
Re: [opensuse-buildservice] DoD rpm download blocked


On 07/07/2016 11:27 AM, Michael Schroeder wrote:
On Thu, Jul 07, 2016 at 11:23:14AM +0200, Michael Schroeder wrote:
On Thu, Jul 07, 2016 at 09:48:41AM +0200, Eike Waldt wrote:
Hi,

when building a kiwi image with obs2.7 and DoD repos, it downloads over
200 Packages and than stays in this state:

- SLES12SP2beta3 (kiwi-image)
no former build, start build
blocked: downloading 22 dod packages

I could not find any log messages related to the Project/repo in which these
packages are or any other information regarding the packages it cannot
download.

Am I missing some logs/files which carry more information or is there
simply no way of debugging this?

You need to check the reposerver log about what went wrong with the
download.

Wait a sec, the scheduler log shoud contain something like
"requesting xxx dod packages from xxx" further down. Isn't that the
case?
Ok, I deleted my repos and added them again to begin with a clear
environment...

Yes, I see these messages:

took 0 seconds to check the packages
requesting 3 dod packages from DoD-SLE-12-SP2-beta3/SLE-HA/x86_64
requesting 16 dod packages from DoD-SLE-12-SP2-beta3/SLE-SDK/x86_64
requesting 2 dod packages from DoD-SLE-12-SP2-beta3/SLE-WE/x86_64
requesting 624 dod packages from
DoD-SLE-12-SP2-beta3/SLES12SP2beta3DVD1/x86_64

The package numbers are counting down in the logs.


I even see now the repos and the packages that are pulled from them (for
ALL repos):

response from RPC dodfetch/DoD-SLE-12-SP2-beta3/SLE-WE/x86_64
(http://obs27:5252/build/DoD-SLE-12-SP2-beta3/SLE-WE/x86_64/_repository?view=binaryversions&binary=ntfs-3g&binary=ntfsprogs)
event scanrepo DoD-SLE-12-SP2-beta3 SLE-WE x86_64
reading packages of repository DoD-SLE-12-SP2-beta3/SLE-WE
scanning repo DoD-SLE-12-SP2-beta3/SLE-WE...
(dirty: 2)

I took the messages from the RPC response and did a "find" in
/srv/obs/build/$Project/$repo/x86_64/:full and found all the rpm
packages that were mentioned.

It seems to me, that the download itself is working, but no notification
about that is passed to the build process.
Or the package list mentioned in the RPC response in not complete.


Cheers,
Michael.


--
Eike Waldt
Linux Consultant
Tel.: +49-175-7241189
Mail: waldt@xxxxxxxxxxxxx

B1 Systems GmbH
Osterfeldstraße 7 / 85088 Vohburg / http://www.b1-systems.de
GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537

< Previous Next >
Follow Ups