Mailinglist Archive: opensuse-buildservice (119 mails)

< Previous Next >
Re: [opensuse-buildservice] OBS 2.7.0 RC 1

On 13.05.2016, at 12:03 , Adrian Schröter <adrian@xxxxxxx> wrote:

This is the trace of a login attempt of an ldap user:

[7e8bd604-d0d0-4cec-abf6-cab400d2b83f] [1683:355.48] Started POST
"/user/do_login" for at 2016-05-13 11:42:07 +0000
[7e8bd604-d0d0-4cec-abf6-cab400d2b83f] [1683:355.48] Processing by
Webui::UserController#do_login as HTML
[7e8bd604-d0d0-4cec-abf6-cab400d2b83f] [1683:355.48] Parameters:
"username"=>"carsten.hoeger", "password"=>"[FILTERED]", "commit"=>"Log
[7e8bd604-d0d0-4cec-abf6-cab400d2b83f] [1683:355.62] Completed 500
Internal Server Error in 139ms (ActiveRecord: 2.8ms | Backend: 0.0ms |
XML: 0.0ms)
[7e8bd604-d0d0-4cec-abf6-cab400d2b83f] [1683:355.63]
NoMethodError (undefined method `kind' for #<Project:0x00000005c5d410>):

This looks more like a complete different problem. Your database has no
"kind" row
in project table? That can't work since quite some time ...

I downloaded the 2.6 appliance and used that since quite some time now
as test system to check updates before applying them to production.

It was successfully running 2.6.9 before I updated to 2.7.

And your migrations worked?

No, they didn’t.

But now I found a way to update which is working.

It seems to be essential to _STOP_ all obs services before
running the entire update process. That includes rpm
updates as well as the db:migrate database update.

I stumbled over that since I ran a tail -f /var/log/mysql.log which revealed
that something started to do all kinds of operations on mysql during the rpm
phase, so I decided to stop all obs related processes.

Following exactly these steps when running on opensuse 13.2 leads to a working
including ldap (even usernames with dots :)):

-------------------------------- [snip 2.6 to 2.7]
for i in /etc/init.d/*obs*; do $i stop; done
systemctl stop apache2

zypper rr OBS:Server:Unstable
zypper ar
zypper ref -s
zypper dup --no-recommends --from OBS_Server_2.7
cd /srv/www/obs/api/
RAILS_ENV="production" rake.ruby2.3 db:migrate

for i in /etc/init.d/*obs*; do $i start; done

systemctl enable obsdodup
systemctl enable obsdeltastore
-------------------------------- [snip 2.6 to 2.7]

Only part missing now is the ldap fallback (the patch you sent me).


kind regards,
Carsten Hoeger
Professional Services

Email: carsten.hoeger@xxxxxxxxxxxxxxxx

Open-Xchange AG, Rollnerstr. 14, 90408 Nuremberg, District Court Nuremberg HRB
Managing Board: Rafael Laguna de la Vera, Carsten Dirks, Uwe Reumuth
Chairman of the Board: Richard Seibt

European Office:
Open-Xchange GmbH, Martinstr. 41, D-57462 Olpe, Germany, District Court Siegen,
HRB 8718
Managing Directors: Frank Hoberg, Martin Kauss

US Office:
Open-Xchange. Inc., 530 Lytton Avenue, Palo Alto, CA 94301, USA

< Previous Next >