Mailinglist Archive: opensuse-buildservice (119 mails)

< Previous Next >
Re: [opensuse-buildservice] OBS 2.7.0 RC 1
Hi,

On 13.05.2016, at 10:58 , Adrian Schröter <adrian@xxxxxxx> wrote:

After the update of my test server (2.6.9 based on the appliance,
openSUSE:13.2),
I can’t even login as admin anymore.

In the webui it displays the error: “No anonymous access. Please log in!”

Is it true that anonymous access is disbaled?

yes

buildservice:/srv/obs # grep anon configuration.xml
<anonymous>off</anonymous>



Will try this setup, it works when using a proxy, but I need to test without.

Or do you use also LDAP for authentification?

yes, I do

Ok, when I turn LDAP mode off, I can login as Admin again.

Didn’t you write that "LDAP support works again” ?

It worked before the update to 2.7 at least.




in the production.log I see:
...
[2227:85.48] 2016-05-13T10:25:01+0000: [Worker(delayed_job.0
host:buildservice pid:2227)] Job ProjectLogRotate#perform (id=68) FAILED (4
prior attempts) with NoMethodError: undefined method `find_by_number' for
#<Class:0x00000003ade5f0>
Did you mean? find_by_number!

This looks like the delayed jobs got not restarted after migration, but this
is independend of your problem.

systemctl restart obsapidelayed

was executed at least

--

kind regards,
Carsten Hoeger
Professional Services



Email: carsten.hoeger@xxxxxxxxxxxxxxxx


-------------------------------------------------------------------------------------
Open-Xchange AG, Rollnerstr. 14, 90408 Nuremberg, District Court Nuremberg HRB
24738
Managing Board: Rafael Laguna de la Vera, Carsten Dirks, Uwe Reumuth
Chairman of the Board: Richard Seibt

European Office:
Open-Xchange GmbH, Martinstr. 41, D-57462 Olpe, Germany, District Court Siegen,
HRB 8718
Managing Directors: Frank Hoberg, Martin Kauss

US Office:
Open-Xchange. Inc., 530 Lytton Avenue, Palo Alto, CA 94301, USA
-------------------------------------------------------------------------------------

< Previous Next >
Follow Ups