Mailinglist Archive: opensuse-buildservice (119 mails)

< Previous Next >
Re: [opensuse-buildservice] Bootstrapping OBS
On Mittwoch, 11. Mai 2016, 17:50:25 wrote Erico Mendonca:
On Dienstag, 10. Mai 2016, 20:42:28 wrote Erico Mendonca:
Em [DATE], "[NAME]" <[ADDRESS]> escreveu:



2) copied all the binary RPMs to a staging area and proceeded as noted
on the documentation (stop the scheduler and move everything to the
corresponding :full directory, each package renamed to just “.rpm”
without a version). Even though a :full.solv file was created after a
while, I still see no packages at all for the project.

source package containers? no, you don't see them.


How should I proceed to replicate these locally without interconnect? I
may be having firewall/proxy issues here.

hm, best way is maybe for you to copy the binaries to some directory, call
"createrepo" manual there and
use that as DoD URL (we should really enable rpm-md meta data on our SLE
medias ...)

Please note that you will need at least also the SDK, depending on what you
want to build.

Working on that right now. I noticed that it won’t accept file:/// URLs, I
had to place the files accessible via http.

right, this is currently a wanted limitation. We may add some option later
to allow it, but we think it should not be used in production...

Hmm, not working here. I get a 502 error after a long time. Does it need
access to anything other than api.opensuse.org on port 443? I’m behind an
authenticated proxy + firewall...

Do you have configured the proxy either in

/etc/sysconfig/proxy

or

/usr/lib/obs/server/BSConfig.pm
our BSConfig::proxy = ...;

?

Do you see error messages in /srv/obs/log/src_server.log ?

Can you reach api.opensuse.org manualy with curl using the proxy from that
server?



Yes, I had the proxy defined in sysconfig, and curl works. But repeating the
osc api command with the —http-full-debug parameter, I was able to see the
proxy error messages. I added “our $proxy = …” and a corresponding “our
$noproxy=…” to BSConfig.pm, and things started working. I’m now able to
perform operations o openSUSE.org projects via interconnect.

However, the frontend search won’t return results from build.opensuse.org. Is
that intentional?

yes

--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >