Mailinglist Archive: opensuse-buildservice (140 mails)

< Previous Next >
[opensuse-buildservice] osc doesn't work on new installation: M2Crypto is needed to access https://api.opensuse.org in a secure way
Dear all!

On a freshly installed LEAP PC I'm seeing this issue invoking osc commands:

osc up
/usr/lib64/python2.7/site-packages/M2Crypto/__m2crypto.so: undefined symbol:
SSLv2_method
M2Crypto is needed to access https://api.opensuse.org in a secure way.
Please install python-m2crypto.

Of course python-m2crypto is already installed. Very similar issues can be
found at https://lists.opensuse.org/opensuse-buildservice/2015-09/msg00015.html
https://lists.opensuse.org/opensuse-buildservice/2015-09/msg00014.html -
unfortunately there is no solution. As response to those messages, here you
find the items asked for:

type -p python
/usr/bin/python

rpm --verify python-base
# no output

rpm -V python-M2Crypto
# no output

python -c "from httplib import HTTPSConnection"
Traceback (most recent call last):
File "<string>", line 1, in <module>
ImportError: cannot import name HTTPSConnection



--
Johannes Weberhofer
Weberhofer GmbH, Austria, Vienna
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups